Bug 612292 - Performance loss querying object database from command line
Summary: Performance loss querying object database from command line
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Steven Dake
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-07 19:23 UTC by Lon Hohberger
Modified: 2016-04-26 14:19 UTC (History)
2 users (show)

Fixed In Version: corosync-1.2.3-12.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 13:53:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
flatiron revision 2987 to fix problem (2.03 KB, patch)
2010-07-07 21:55 UTC, Steven Dake
no flags Details | Diff

Description Lon Hohberger 2010-07-07 19:23:46 UTC
Description of problem:

In order to report errors with /dev/shm being full, writes zeroes to all of the pages.  This was done to resolve bug 607738.

This introduces a performance regression for utilities which query a couple of things from the object database (ex: rgmanager's cmdline utility 'clulog').

Version-Release number of selected component (if applicable): 1.2.3-9

How reproducible: 100%

Steps to Reproduce: 
1. time clulog -s7 hi
  
Actual results: 1+ second per run

Expected results: faster ;)

Additional info: clulog is not the only piece of software affected; it just happens to be the one I noticed.

A couple of cursory tests with Steve showed that increasing the buffer size to 4096 had a significant improvement, while values larger than that had little improvement.

Comment 2 Steven Dake 2010-07-07 21:55:06 UTC
Created attachment 430185 [details]
flatiron revision 2987 to fix problem

Comment 3 Lon Hohberger 2010-07-07 22:53:23 UTC
[root@crackle ~]# time clulog -s7 hi
hi

real    0m0.211s
user    0m0.007s
sys     0m0.070s

[root@crackle ~]# rpm -q corosync corosynclib corosynclib-devel
corosync-1.2.3-12.el6.x86_64
corosynclib-1.2.3-12.el6.x86_64
corosynclib-devel-1.2.3-12.el6.x86_64

Works for me.

Comment 5 releng-rhel@redhat.com 2010-11-15 13:53:53 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.