Bug 612296 (CVE-2010-2445) - CVE-2010-2445 freeciv: arbitrary file disclosure and command execution vulnerabilities
Summary: CVE-2010-2445 freeciv: arbitrary file disclosure and command execution vulner...
Status: NEW
Alias: CVE-2010-2445
Product: Security Response
Classification: Other
Component: vulnerability   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: public=20100314,reported=20100707,sou...
Keywords: Security
Depends On: 612297
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-07 19:43 UTC by Vincent Danen
Modified: 2015-08-19 08:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vincent Danen 2010-07-07 19:43:12 UTC
Common Vulnerabilities and Exposures assigned an identifier CVE-2010-2445 to
the following vulnerability:

Name: CVE-2010-2445
URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-2445
Assigned: 20100624
Reference: MLIST:[oss-security] 20100610 CVE requests: maradns, freeciv, rbot, gitolite, gource, shib, kvirc
Reference: URL: http://www.openwall.com/lists/oss-security/2010/06/09/4
Reference: MLIST:[oss-security] 20100624 Re: CVE requests: maradns, freeciv, rbot, gitolite, gource, shib, kvirc
Reference: URL: http://www.openwall.com/lists/oss-security/2010/06/24/5
Reference: CONFIRM: http://gna.org/bugs/?15624
Reference: OSVDB:65192
Reference: URL: http://www.osvdb.org/65192

freeciv 2.2 before 2.2.1 and 2.3 before 2.3.0 allows attackers to read
arbitrary files or execute arbitrary commands via scenario that
contains Lua functionality, related to the (1) os, (2) io, (3)
package, (4) dofile, (5) loadfile, (6) loadlib, (7) module, and (8)
require modules or functions.


Freeciv in Fedora is currently vulnerable (2.2.0) whereas upstream 2.2.1 corrects the issues.

Comment 1 Vincent Danen 2010-07-07 19:44:43 UTC
Created freeciv tracking bugs for this issue

Affects: fedora-all [bug 612297]


Note You need to log in before you can comment on or make changes to this bug.