Bug 612334 - Please create EL-6 branch for libesmtp
Please create EL-6 branch for libesmtp
Status: CLOSED WORKSFORME
Product: Fedora EPEL
Classification: Fedora
Component: libesmtp (Show other bugs)
el6
All Linux
low Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-07 18:17 EDT by Pawel Salek
Modified: 2013-01-10 01:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-19 15:43:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pawel Salek 2010-07-07 18:17:19 EDT
Package Change Request
======================
Package Name: libesmtp
New Branches: EL-6
Owners: pawsa
Comment 1 Pawel Salek 2010-07-20 17:35:36 EDT
ping?
Comment 2 Kevin Fenzi 2010-08-03 14:23:17 EDT
GIT done (by process-git-requests).
Comment 3 Pawel Salek 2010-08-11 16:39:07 EDT
I do not see libesmtp el6 branch created yet:
$ fedpkg clone libesmtp
Cloning into libesmtp...
remote: Counting objects: 194, done.
remote: Compressing objects: 100% (83/83), done.
remote: Total 194 (delta 99), reused 187 (delta 95)
Receiving objects: 100% (194/194), 24.92 KiB, done.
Resolving deltas: 100% (99/99), done.
$ cd libesmtp
$ git branch -a
  el6
* master
  remotes/origin/HEAD -> origin/master
  remotes/origin/el4/master
  remotes/origin/el5/master
  remotes/origin/f10/master
  remotes/origin/f11/master
  remotes/origin/f12/master
  remotes/origin/f13/master
  remotes/origin/f14/master
  remotes/origin/f7/master
  remotes/origin/f8/master
  remotes/origin/f9/master
  remotes/origin/fc6/master
  remotes/origin/master

 When I try to create remote el6 branch, I get:
[pawsa@damage libesmtp]$ git branch el6
[pawsa@damage libesmtp]$ git push --all
Total 0 (delta 0), reused 0 (delta 0)
remote: C refs/heads/el6 pawsa DENIED by refs/heads/el[0-9]
remote: error: hook declined to update refs/heads/el6
To ssh://pawsa@pkgs.fedoraproject.org/libesmtp
 ! [remote rejected] el6 -> el6 (hook declined)
error: failed to push some refs to 'ssh://pawsa@pkgs.fedoraproject.org/libesmtp'

How can I fix it?
Comment 4 Mark Chappell 2010-09-15 05:15:13 EDT
Resetting the cvs flag to get the attention of the vcs admins

@Pawel Normally you'd do this on the package review (https://bugzilla.redhat.com/show_bug.cgi?id=165956)
Comment 5 Mark Chappell 2010-09-15 05:45:29 EDT
Oops, apologies, That's not the review (It was just labeled as such), there doesn't seem to be one...
Comment 6 Kevin Fenzi 2010-09-16 19:10:17 EDT
Sadly, something is weird with the libesmtp git repo now. 

I see a commit email saying: 

The ref 'refs/el6/master' was created pointing to:

 dc42e88e757a00bef658b915510cd19ed1c9491a

This is unexpected because:

 'refs/el6/master' is not in refs/heads/ or refs/tags/

I'll see about someone who knows git more than I fixing it up. 
Sorry for the trouble.
Comment 7 Jesse Keating 2010-09-17 04:03:43 EDT
I'm not entirely sure what's going on here, but I did another mkbranch call for el6/master and it seems to have gone through, kindof.  Give it a try and if things are still wonky we'll re-convert the repo and reply the changes made thus far.
Comment 8 Pawel Salek 2010-09-19 15:43:07 EDT
This appears to have helped - thanks!
Comment 9 Kevin Fenzi 2010-09-20 23:41:06 EDT
Clearing the cvs flag. Feel free to reset if you need anything further.

Note You need to log in before you can comment on or make changes to this bug.