Bug 612395 - The patents have expired!
The patents have expired!
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On: 547532
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 01:37 EDT by Ernesto Manríquez
Modified: 2011-05-16 22:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-16 22:34:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ghostscript 690621 None None None Never

  None (edit)
Description Ernesto Manríquez 2010-07-08 01:37:09 EDT
According to http://bugs.ghostscript.com/show_bug.cgi?id=690621 , we can safely enable the bytecode interpreter in Fedora and all the code covered by those patents. They have expired since May, 2010.

Legal, is this safe? Can we make a quick import of the RPM Fusion package into Fedora?
Comment 1 Behdad Esfahbod 2010-07-08 01:44:44 EDT
They expired in October 2009 in fact.

We enabled them, but had to disable since it caused regression with autohinting stuff.  There's a bug filed about it with lots of history, can't find it right now.
Comment 2 Kevin Kofler 2010-07-08 02:38:54 EDT
Bug 547532.
Comment 3 Bug Zapper 2010-07-30 08:28:21 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Fedora Admin XMLRPC Client 2010-09-22 09:54:51 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2010-09-22 09:59:59 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Ernesto Manríquez 2011-05-16 22:34:46 EDT
The patented bytecode is with us since Fedora 15 Beta.

Note You need to log in before you can comment on or make changes to this bug.