Bug 612406 - SELinux is preventing /usr/libexec/dovecot/dovecot-lda "search" access on /var/run/dovecot.
SELinux is preventing /usr/libexec/dovecot/dovecot-lda "search" access o...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
setroubleshoot_trace_hash:8b95bd9a7be...
:
: 612405 616344 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 02:59 EDT by Jiri Kastner
Modified: 2015-06-18 05:56 EDT (History)
6 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-31.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:35:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Kastner 2010-07-08 02:59:16 EDT
Summary:

SELinux is preventing /usr/libexec/dovecot/dovecot-lda "search" access on
/var/run/dovecot.

Detailed Description:

[deliver has a permissive type (postfix_local_t). This access was not denied.]

SELinux denied access requested by deliver. It is not expected that this access
is required by deliver and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:postfix_local_t:s0
Target Context                system_u:object_r:dovecot_var_run_t:s0
Target Objects                /var/run/dovecot [ dir ]
Source                        deliver
Source Path                   /usr/libexec/dovecot/dovecot-lda
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           dovecot-2.0-0.8.beta6.20100630.el6
Target RPM Packages           dovecot-2.0-0.8.beta6.20100630.el6
Policy RPM                    selinux-policy-3.7.19-30.el6
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32-42.el6.x86_64 #1 SMP Wed Jun 30 15:15:28
                              EDT 2010 x86_64 x86_64
Alert Count                   9
First Seen                    Thu 08 Jul 2010 08:15:06 AM CEST
Last Seen                     Thu 08 Jul 2010 08:55:09 AM CEST
Local ID                      142b5aab-6bb1-43c2-ae98-19bee1feabc9
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1278572109.830:33911): avc:  denied  { search } for  pid=4608 comm="deliver" name="dovecot" dev=sda7 ino=5113417 scontext=system_u:system_r:postfix_local_t:s0 tcontext=system_u:object_r:dovecot_var_run_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1278572109.830:33911): arch=c000003e syscall=42 success=yes exit=68719476864 a0=6 a1=7fff6bb328f0 a2=6e a3=7fff6bb32670 items=0 ppid=4607 pid=4608 auid=4294967295 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=4294967295 comm="deliver" exe="/usr/libexec/dovecot/dovecot-lda" subj=system_u:system_r:postfix_local_t:s0 key=(null)



Hash String generated from  catchall,deliver,postfix_local_t,dovecot_var_run_t,dir,search
audit2allow suggests:

#============= postfix_local_t ==============
allow postfix_local_t dovecot_var_run_t:dir search;
Comment 1 Jiri Kastner 2010-07-08 03:02:26 EDT
i'm running fetchmail with configuration stated bellow, which produces selinux denials:

poll mail.corp.redhat.com port 993 plugin "openssl s_client -connect %h:%p"
protocol IMAP 
user username there with pass xxxxxxxx is local-username
options fetchall
mda "/usr/libexec/dovecot/deliver"
Comment 2 Jiri Kastner 2010-07-08 03:03:50 EDT
bug 612405 is another one, produced by same process
Comment 4 Miroslav Grepl 2010-07-08 09:01:14 EDT
The proper label for /usr/libexec/dovecot/dovecot-lda is needed.

Jiri,
thanks for testing.
Comment 5 Miroslav Grepl 2010-07-08 09:01:40 EDT
*** Bug 612405 has been marked as a duplicate of this bug. ***
Comment 6 Miroslav Grepl 2010-07-09 07:52:15 EDT
Fixed in selinux-policy-3.7.19-31.el6.noarch
Comment 9 Miroslav Grepl 2010-07-21 11:16:03 EDT
*** Bug 616344 has been marked as a duplicate of this bug. ***
Comment 11 releng-rhel@redhat.com 2010-11-10 16:35:12 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.