Bug 612423 - etc/udev/rules.d/60-raw.rules gets trashed by util-linux on update.
etc/udev/rules.d/60-raw.rules gets trashed by util-linux on update.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: util-linux (Show other bugs)
5.6
All Linux
high Severity high
: rc
: ---
Assigned To: Karel Zak
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 03:45 EDT by Wade Mealing
Modified: 2011-01-13 18:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 18:45:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0085 normal SHIPPED_LIVE util-linux bug fix update 2011-01-12 12:29:18 EST

  None (edit)
Description Wade Mealing 2010-07-08 03:45:49 EDT
Description of problem:

Util-linux overwrites /etc/udev/rules.d/60-raw.rules when updated.
The old version of the file is saved, but I see no reason why it should overwrite this file in the first place.

This file _empty_ by default except just one comment instructing how it is supposed to be used.

So it is clearly intended to be changed by the user.

How reproducible:

The file should not be touched if changed by user since it is purely a user generated config file.

Steps to Reproduce:
1. Have a custom raw.rules file.
2. Update util linux
3. Wait.
  
Actual results:

Custom config gets trashed, oracle wont work on next boot.

Expected results:

Config file to get 

Additional info:

Mark this as a config file with noreplace and it behaves as you'd expect.

%config(noreplace)


%if %{include_raw}
/bin/raw
%config(noreplace) %{_sysconfdir}/udev/rules.d/60-raw.rules
%endif

Additional additional info:

More people are allergic to cow's milk than any other food.
Comment 5 errata-xmlrpc 2011-01-13 18:45:35 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0085.html

Note You need to log in before you can comment on or make changes to this bug.