Bug 612445 - NetworkManager does not support DHCPv6-only configurations
Summary: NetworkManager does not support DHCPv6-only configurations
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Dan Williams
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On: 623216
Blocks: 582286
TreeView+ depends on / blocked
 
Reported: 2010-07-08 09:05 UTC by Marian Ganisin
Modified: 2010-11-10 19:31 UTC (History)
2 users (show)

Fixed In Version: NetworkManager-0.8.1-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 623216 (view as bug list)
Environment:
Last Closed: 2010-11-10 19:31:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marian Ganisin 2010-07-08 09:05:50 UTC
Description of problem:
I tried to configure anaconda to use dhcp for ipv6 configuration, however it doesn't even send dhcpv6 request.

I tried ipv6=dhcp on command line as well as proper choice in configuration dialog, nothing was working.

Version-Release number of selected component (if applicable):
RHEL6.0-20100707.4
anaconda-13.21.56-1.el6

Comment 1 Radek Vykydal 2010-07-08 10:26:56 UTC
NetworkManager plugin ifcfg-rh doesn't support dhcpv6 yet (DHCPV6C ifcfg option).

Comment 2 Marian Ganisin 2010-07-08 10:32:58 UTC
Even more, neighbor discovery is used instead of dhcp if available.

Comment 3 Dan Williams 2010-07-12 22:10:31 UTC
Note that DHCPv6 is *not* a full IPv6 configuration method since DHCPv6 cannot return the gateway to use to access external networks.  You need a combination of router advertisements *and* DHCPv6 (which is used when the router advertisement sets the "otherconf" or "managed" bits).

Comment 4 Dan Williams 2010-07-12 22:11:56 UTC
There was support for DHCPv6-only, but since DHCPv6 doesn't return a gateway (and the DHCPv6 server is not necessarily the gateway) DHCPv6-only support was removed from NM in commit a729d2f649fefc77fcff7ad250c5c403a4dd59b7

Comment 5 Dan Williams 2010-07-12 22:42:52 UTC
Ok, based on discussion I'll revert the revert and we'll get back DHCPv6-only functionality.

Comment 6 Marian Ganisin 2010-07-13 05:56:11 UTC
Just for a clarification, I reported anaconda (actually NM on backend) does not even send dhcpv6 request even if explicitly requested in configuration dialog, that's the issue in this report. This doesn't necessarily require dhcpv6-only configuration, just dhcpv6 should be used when requested.

Comment 7 Dan Williams 2010-07-13 23:52:46 UTC
It does require DHCPv6-only functionality, because when DHCPv6 is requested, you're asking to *not* use autoconf, but instead to use only DHCPv6.

Normal IPv6 networks would have router advertisements enabled with the "Managed" bit set, at which point NetworkManager will then automatically start DHCPv6 and use the returned information for configuration.

What you're asking the installer/NM to do here is to ignore IPv6 autoconfiguration and manually do a DHCPv6 request, presumably because your network does not have router advertisements enabled.  Which is odd (and not really how IPv6 is supposed to work) but is apparently a configuration that people require.

Comment 8 Marian Ganisin 2010-07-14 08:20:13 UTC
(In reply to comment #7)

> Normal IPv6 networks would have router advertisements enabled with the
> "Managed" bit set...

This is stateless configuration.

> What you're asking the installer/NM to do here is to ignore IPv6
> autoconfiguration and manually do a DHCPv6 request

I am asking here for stateful DHCPv6 configuration. This is what I assume if I choose DHCPv6 in network configuration dialog of installer. IP address (as well as other options) should be assigned by DHCP server.

Additionally, I assume working network configuration in any case (correct router set for example).

Comment 9 Marian Ganisin 2010-07-14 08:37:42 UTC
Just to be clear, maybe the options in anaconda are wrong (or maybe my understanding is wrong), I can't decide.

Anaconda provides these 2 automatic configuration options:

 * Automatic neighbor discovery
   - With this option I assume autoconfiguration including stateless DHCPv6
     if available.

 * Dynamic IP configuration (DHCPv6)
   - Here I assume complete stateful DHCPv6 configuration, doesn't matter
     if 'M' bit in router advertisement is set or not.

Comment 10 Dan Williams 2010-07-14 15:27:14 UTC
(In reply to comment #9)
> Just to be clear, maybe the options in anaconda are wrong (or maybe my
> understanding is wrong), I can't decide.
> 
> Anaconda provides these 2 automatic configuration options:
> 
>  * Automatic neighbor discovery
>    - With this option I assume autoconfiguration including stateless DHCPv6
>      if available.
> 
>  * Dynamic IP configuration (DHCPv6)
>    - Here I assume complete stateful DHCPv6 configuration, doesn't matter
>      if 'M' bit in router advertisement is set or not.    

That's probably correct, but "Automatic" will *also* do stateful DHCPv6 if the router sets the 'M' bit.  I'd assume the DHCPv6 option there just ignores router advertisements completely.

Comment 22 Vladimir Benes 2010-08-31 11:43:24 UTC
moving to verified as approved by QE member
-> VERIFIED

Comment 23 releng-rhel@redhat.com 2010-11-10 19:31:40 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.