Bug 612529 - rhn_register --nox, after resize of terminal window, doesn't properly redraw screen
rhn_register --nox, after resize of terminal window, doesn't properly redraw ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 09:11 EDT by Jiri Kastner
Modified: 2010-07-08 10:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 10:04:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhn_register inside resized terminal (20.04 KB, image/png)
2010-07-08 09:11 EDT, Jiri Kastner
no flags Details

  None (edit)
Description Jiri Kastner 2010-07-08 09:11:33 EDT
Created attachment 430352 [details]
rhn_register inside resized terminal

Description of problem:
when i resize window of gnome-terminal (xterm, roxterm...), while running 'rhn_register --nox' and go back, window is redrawn improperly, not able to see all buttons.

Version-Release number of selected component (if applicable):
rhn-client-tools-1.0.0-24.el6.noarch
rhn-setup-1.0.0-24.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. run 'rhn_register --nox'
2. enter username and password
3. when on profile details screen, resize terminal window
4. go back
5. check results
  
Actual results:
see 

Expected results:
when terminal window resized, rhn_register will redraw screens properly

Additional info:
Comment 1 Jan Pazdziora 2010-07-08 09:50:48 EDT
Taking.
Comment 2 Jan Pazdziora 2010-07-08 09:51:19 EDT
Not a regression against RHEL 5, not a RHEL 6.0 material.
Comment 3 Jan Pazdziora 2010-07-08 09:52:26 EDT
Actually, this seems to be a known limitation of the underlying newt library. Devel nack.
Comment 4 RHEL Product and Program Management 2010-07-08 10:04:23 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.