Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 612564 - 389-admin should use mod_cgid instead of mod_cgi
389-admin should use mod_cgid instead of mod_cgi
Status: CLOSED DEFERRED
Product: 389
Classification: Community
Component: Admin (Show other bugs)
1.2.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Rich Megginson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 10:27 EDT by Fabio Erculiani
Modified: 2015-11-19 15:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 15:09:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Erculiani 2010-07-08 10:27:10 EDT
Description of problem:
389-admin is improperly using the cgi module. When using a
multithreaded MPM (worker), mod_cgid had to be used. It happens that
389-admin needs apache (with worker MPM) and mod_cgi (and not
mod_cgid).
mod_cgid fork() itself from the main httpd process while mod_cgi
doesn't. That's why password_pipe() works fine with the latter.

Also see:
http://lists.fedoraproject.org/pipermail/389-users/2010-July/011710.html
http://httpd.apache.org/docs/2.2/mod/mod_cgid.html
Comment 2 Martin Kosek 2012-01-04 08:31:15 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/83
Comment 4 Noriko Hosoi 2015-11-19 15:09:14 EST
Closing this bug since we moved to the ticket system:
https://fedorahosted.org/389/ticket/83

Note You need to log in before you can comment on or make changes to this bug.