Bug 612569 - cannot unlock luks partition using prompt and rhgb
cannot unlock luks partition using prompt and rhgb
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: plymouth (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 10:32 EDT by Vladimir Benes
Modified: 2010-11-10 16:21 EST (History)
2 users (show)

See Also:
Fixed In Version: plymouth-0.8.3-17.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:21:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fstab (952 bytes, text/plain)
2010-07-14 03:38 EDT, Vladimir Benes
no flags Details
crypttab (90 bytes, text/plain)
2010-07-14 03:40 EDT, Vladimir Benes
no flags Details

  None (edit)
Description Vladimir Benes 2010-07-08 10:32:31 EDT
Description of problem:
if I start normal rhgb boot but press some keys to see boot logs I cannot unlock my home partition
The cursor drops one line down after first key press and no starts are shown while typing the password 
after hitting enter there is No key available with this passphrase. error message shown and I am prompted for the key again. 

Version-Release number of selected component (if applicable):
snap7 

How reproducible:


Steps to Reproduce:
1.boot up using rhgb
2.press down arrow to see logs
3.type luks password to open a partition
  
Actual results:
cannot unlock partition

Expected results:
can unlock it

Additional info:
Comment 1 Vladimir Benes 2010-07-08 10:38:31 EDT
I am not sure if plymouth or some other components should be selected... 
just my home partition is locked 

plymouth-0.8.3-11.el6.x86_64
dracut-004-24.el6.noarch
cryptsetup-luks-1.1.2-1.el6.x86_64
cryptsetup-luks-libs-1.1.2-1.el6.x86_64
kernel-2.6.32-44.el6.x86_64
Comment 2 Ray Strode [halfline] 2010-07-08 12:59:01 EDT
seems to work here, but i'll do a fresh install

can you attach your /etc/crypttab and /etc/fstab ?
Comment 4 Ray Strode [halfline] 2010-07-13 23:51:42 EDT
reading comment 0 carefully, it sounds like plymouthd may be crashing.  certainly no asterisks suggests that cryptsetup is reading the keyboard input and not plymouth.  Proposing for blocker until it's determined if this is a crasher or not.

vbenes can you attach those files please?
Comment 5 Vladimir Benes 2010-07-14 03:38:52 EDT
Created attachment 431692 [details]
fstab
Comment 6 Vladimir Benes 2010-07-14 03:40:25 EDT
Created attachment 431693 [details]
crypttab
Comment 7 Vladimir Benes 2010-07-14 04:09:04 EDT
I can see error like this: Couldn't start boot splash, no such file or directory
Comment 8 Ray Strode [halfline] 2010-07-16 17:19:03 EDT
So what's probably going on here is you have a separate /usr partition

when you hit escape (or down arrow or whatever) in the brief window between when / and /usr are mounted the details plugin isn't available to get loaded and plymouth is probably croaking at that point.

We should make details be a "builtin" so it's always available.
Comment 9 Vladimir Benes 2010-07-19 04:56:55 EDT
yes, that's right I have my /usr dir on a separate partition
Comment 10 Ray Strode [halfline] 2010-07-27 18:53:37 EDT
I'm building a version of plymouth now that builds details into the binary.

Please test this!  Since this involves the very early part of boot up, we really need to make sure this fix works and doesn't break anything else.
Comment 12 Vladimir Benes 2010-07-29 07:35:43 EDT
Still not fixed, but the behaviour is a bit better it works now unless you press up or down arrow (I use this keys to switch to console) while prompted for password.
After the arrow pressing the "Could not start boot splash: No such file or directory" error occurs and you are unable to fulfil the request.
Comment 13 Vladimir Benes 2010-07-29 07:38:44 EDT
It behaves as described above also if you are prompted for password in graphical mode and you press arrow
Comment 14 Ray Strode [halfline] 2010-08-02 17:26:55 EDT
just to be sure, you did rebuild the initrd after installing the updated plymouth, right?

I'm looking through the patch and can't come up with a plausible explanation for the behavior you're describing.

I'll probably need to do a fresh install and reproduce to track this down.  Before I do that, I'd like confirmation from you that after installing the updated package you ran

/usr/libexec/plymouth/plymouth-update-initrd

or installed a new kernel.
Comment 15 Vladimir Benes 2010-08-03 05:28:07 EDT
(In reply to comment #14)
> just to be sure, you did rebuild the initrd after installing the updated
> plymouth, right?
> 
yes, I've installed new -54 kernel and also rebuild initrd with above command

> I'm looking through the patch and can't come up with a plausible explanation
> for the behavior you're describing.
>
the behaviour I see is this: wait until graphical password prompt is shown, press up/down arrow and try to enter the passphrase into text mode prompt.
I am unable to do this. No stars as I write just cursor jumps to next line and No key available with this passphrase" occurs after a while.
Comment 16 Ray Strode [halfline] 2010-08-09 14:05:36 EDT
I did a guest install of plymouth with your configuration and was able to reproduce the problem.  The issue was that the Makefile lacked "-rdynamic" in its CFLAGS.

I never noticed this in local builds on my primary workstation, because I have -rdynamic in my default CFLAGS.

This is building now.
Comment 18 Vladimir Benes 2010-08-16 11:37:38 EDT
everything works as expected now, thanks for fixing it
-> VERIFIED
Comment 19 releng-rhel@redhat.com 2010-11-10 16:21:14 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.