Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 612665 - Plymouth password icon could use some indication it's for a hard drive password
Plymouth password icon could use some indication it's for a hard drive password
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: plymouth (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 14:13 EDT by Subhendu Ghosh
Modified: 2016-10-04 00:30 EDT (History)
6 users (show)

See Also:
Fixed In Version: plymouth-0.8.3-20.el6
Doc Type: Bug Fix
Doc Text:
Previously, the system prompted for a password on boot but provided no hint as to what the password was for. That caused unnecessary confusion for some users, who didn't know which of their passwords to enter. With this update, a hard drive icon has been added to prompts associated with encrypted disk volumes and the password prompts for encrypted disks are now easy to recognize.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 10:02:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
encrypted drive icon suitable for the purpose (94.93 KB, application/octet-stream)
2010-12-14 17:53 EST, Jakub Steiner
no flags Details
old vs. new icon comparison (5.59 KB, image/png)
2011-03-11 07:24 EST, Jiri Koten
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0686 normal SHIPPED_LIVE plymouth bug fix update 2011-05-18 14:10:27 EDT

  None (edit)
Description Subhendu Ghosh 2010-07-08 14:13:15 EDT
Description of problem:

Install RHEL6 B2 on encrypted volume.

On boot the systems prompts for a password - but provides no hint what the password is for. 


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Install on encrypted volume
2. reboot
3. prompted for password
  
Actual results:

no hints on what the password is for.

Expected results:

hints on what the passowrd is for.

Useful if different volumes have different passwords.
Additional info:
Comment 2 Ray Strode [halfline] 2010-07-08 15:05:02 EDT
So the issue here is we don't have access to fonts, translations, etc until the root filesystem is mounted.

It's not a problem in practice, though, because in most circumstanced we only need to know one thing before mounting the root filesystem. Namely, we need to know the password to mount the root filesystem with.

Since it's only one thing, and the user already knows he/she will need to enter it to continue, conveying "nows the time to type your password" is all we need to do.  We accomplish this with a "lock icon" and a text entry field on screen.

We could potentially change the lock icon to a hard drive icon with a lock emblem or some such.  That would make it even clearer it's a "hard drive password" and not just a password.
Comment 5 Ray Strode [halfline] 2010-07-16 16:15:00 EDT
This missed the non-blocker deadline, proposing for 6.1
Comment 7 Ray Strode [halfline] 2010-11-30 13:56:12 EST
ack if I can get suitable artwork
Comment 9 Jakub Steiner 2010-12-14 17:53:13 EST
Created attachment 468724 [details]
encrypted drive icon suitable for the purpose

SVG included as source,  not intended for installation
Comment 13 Jiri Koten 2011-03-11 07:24:09 EST
Created attachment 483701 [details]
old vs. new icon comparison

New drive icon from comment 9 is present in plymouth-0.8.3-22.el6.
Comment 15 Tomas Capek 2011-04-28 11:09:56 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the system prompted for a password on boot but provided no hint as to what the password was for. That caused unnecessary confusion for some users, who didn't know which of their passwords to enter. With this update, a hard drive icon has been added to prompts associated with encrypted disk volumes and the password prompts for encrypted disks are now easy to recognize.
Comment 16 errata-xmlrpc 2011-05-19 10:02:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0686.html

Note You need to log in before you can comment on or make changes to this bug.