Bug 612673 - publican 2.0 ignoring max_image_width
Summary: publican 2.0 ignoring max_image_width
Status: CLOSED NOTABUG
Alias: None
Product: Publican
Classification: Community
Component: publican   
(Show other bugs)
Version: 1.6
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jeff Fearn
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-08 18:27 UTC by Deon Ballard
Modified: 2010-11-24 04:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 22:04:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
publican.cfg (161 bytes, application/octet-stream)
2010-07-08 21:41 UTC, Deon Ballard
no flags Details
xml file (73.58 KB, text/xml)
2010-07-08 21:43 UTC, Deon Ballard
no flags Details
HTML with the sizing at 444px (54.15 KB, text/html)
2010-07-08 21:44 UTC, Deon Ballard
no flags Details

Description Deon Ballard 2010-07-08 18:27:51 UTC
I have the max_image_width parameter set to 700 in my publican.cfg file, but it is ignoring it and using 444 instead.

Comment 1 Ruediger Landmann 2010-07-08 21:25:22 UTC
I cannot reproduce this on Fedora 13.

* I downloaded an image 2118 pixels wide -- http://upload.wikimedia.org/wikipedia/commons/5/50/Rue-de-paris-film102jpg.jpg

* renamed the image to "tower.jpg" and placed it in the en-US/images directory of a book

* placed the following in the XML of the book:
<mediaobject>
<imageobject>
<imagedata fileref="images/tower.jpg" format="JPG"/>
</imageobject>
<textobject>
<phrase>The Eiffel Tower</phrase>
</textobject>
</mediaobject>

* set the following in the publican.cfg file:
max_image_width: 3000

* built the book. 

The image was in the book at apparently full size (I confess I didn't actually measure it, but it wouldn't fit on a monitor 1920 wide without scrolling sideways)

I then set:
max_image_width: 1000

The image seemed to be scaled appropriately.

Could you please include the XML that you used and the line from your publican.cfg file?

Comment 2 Deon Ballard 2010-07-08 21:41:43 UTC
Created attachment 430484 [details]
publican.cfg

Comment 3 Deon Ballard 2010-07-08 21:43:16 UTC
Created attachment 430486 [details]
xml file

This is happening on every file in the book, naturally. I just uploaded the one; the svn repo is http://svn.devel.redhat.com/cgi-bin/viewvc.cgi/ecs/JON/2.4/Basic_Admin_Guide/en-US/, if you want the whole thing.

Comment 4 Deon Ballard 2010-07-08 21:44:26 UTC
Created attachment 430487 [details]
HTML with the sizing at 444px

Comment 5 Deon Ballard 2010-07-08 21:45:18 UTC
If it helps, I'm on RHEL 5.4 and the brand is JBoss (package version 1.9-0.el5).

Comment 6 Jeff Fearn 2010-07-08 22:04:18 UTC
This limit is a policy imposed by the JBoss brand.

[publican-jboss]$ grep max overrides.cfg 
max_image_width: 444

It's probably better to discuss this on the internal docs comms channels as it's not related to publican development.


Note You need to log in before you can comment on or make changes to this bug.