Bug 612783 - [abrt] crash in pyvnc2swf-0.9.5-8.fc13: vnc2swf-play:27:<module>:ImportError: No module named pygame
[abrt] crash in pyvnc2swf-0.9.5-8.fc13: vnc2swf-play:27:<module>:ImportError:...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pyvnc2swf (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: David Timms
Fedora Extras Quality Assurance
abrt_hash:632a544b
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 21:52 EDT by dweb98
Modified: 2011-06-29 09:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-29 09:47:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (533 bytes, text/plain)
2010-07-08 21:52 EDT, dweb98
no flags Details

  None (edit)
Description dweb98 2010-07-08 21:52:43 EDT
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: python /usr/bin/vnc2swf-play /media/Fedora-12-i686-L/home/don/Videos/PBSPlayer.swf
comment: Downloaded and tried to play an .swf file and it crashed. 
component: pyvnc2swf
executable: /usr/bin/vnc2swf-play
kernel: 2.6.33.5-124.fc13.i686
package: pyvnc2swf-0.9.5-8.fc13
reason: vnc2swf-play:27:<module>:ImportError: No module named pygame
release: Fedora release 13 (Goddard)

backtrace
-----
vnc2swf-play:27:<module>:ImportError: No module named pygame

Traceback (most recent call last):
  File "/usr/bin/vnc2swf-play", line 27, in <module>
    import pygame
ImportError: No module named pygame

Local variables in innermost frame:
__builtins__: <module '__builtin__' (built-in)>
__file__: '/usr/bin/vnc2swf-play'
__package__: None
sys: <module 'sys' (built-in)>
__name__: '__main__'
subprocess: <module 'subprocess' from '/usr/lib/python2.6/subprocess.pyc'>
os: <module 'os' from '/usr/lib/python2.6/os.pyc'>
__doc__: None
Comment 1 dweb98 2010-07-08 21:52:45 EDT
Created attachment 430519 [details]
File: backtrace
Comment 2 David Timms 2010-07-09 08:41:49 EDT
(In reply to comment #0)
> /media/Fedora-12-i686-L/home/don/Videos/PBSPlayer.swf
> comment: Downloaded and tried to play an .swf file and it crashed. 
what method did you use to begin playback of your downloaded file ?

> ImportError: No module named pygame
Can you please give the result of:
rpm -qi pygame
Comment 3 dweb98 2010-07-10 13:47:22 EDT
I opened up the .swf file from within Krusader.

Here is the results from rpm -qi pygame...
[root@fedora13-gatewaygt5408 don]# rpm -qi pygame
package pygame is not installed

I installed pygame with Package Manager for GNOME. Here's the Terminal Output...
[root@fedora13-gatewaygt5408 don]# rpm -qi pygame
Name        : pygame                       Relocations: (not relocatable)
Version     : 1.9.1                             Vendor: Fedora Project
Release     : 1.fc13                        Build Date: Wed 14 Oct 2009 07:50:10 AM CDT
Install Date: Sat 10 Jul 2010 11:32:02 AM CDT      Build Host: xenbuilder4.fedora.phx.redhat.com
Group       : Development/Languages         Source RPM: pygame-1.9.1-1.fc13.src.rpm
Size        : 6654457                          License: LGPLv2+
Signature   : RSA/SHA256, Thu 04 Feb 2010 10:20:18 AM CST, Key ID 7edc6ad6e8e40fde
Packager    : Fedora Project
URL         : http://www.pygame.org
Summary     : Python modules for writing games
Description :
Pygame is a set of Python modules designed for writing games. It is
written on top of the excellent SDL library. This allows you to create
fully featured games and multimedia programs in the python language.
Pygame is highly portable and runs on nearly every platform and
operating system.
[root@fedora13-gatewaygt5408 don]#

Now lets see if anything changes with an .swf file when started in Krusader. It is now set to open .swf's with vnc2swf Screen Recordings Player. It will open the player without crashing, but nothing happens in the window. I noticed the PyPar2 App in Accessories and ran the .swf through it. I got several processed files, but nothing on my machine will play them or display them. I tried VLC, MPlayer, KMPlayer, Kaffine. I even tried Importing the PBSPlayer.swf.par2 into Kino. But got tired of waiting to see if that would work and canceled it.
Here's the list including my original .swf file.
/home/don/Videos/PBSPlayer.swf
/home/don/Videos/PBSPlayer.swf.par2
/home/don/Videos/PBSPlayer.swf.par2.i420
/home/don/Videos/PBSPlayer.swf.par2.pcm
/home/don/Videos/PBSPlayer.swf.vol000+01.par2
/home/don/Videos/PBSPlayer.swf.vol001+02.par2
/home/don/Videos/PBSPlayer.swf.vol003+04.par2
/home/don/Videos/PBSPlayer.swf.vol007+08.par2
/home/don/Videos/PBSPlayer.swf.vol015+16.par2
/home/don/Videos/PBSPlayer.swf.vol031+32.par2
/home/don/Videos/PBSPlayer.swf.vol063+38.par2

Interesting, but all I was really trying to do in the first place was download and watch a Video with the Fl - Flash and Video Downloader - Firefox Addon. It had a long list of .swf files and I couldn't tell which ones were the actual video that I wanted. I later installed and used the DownloadHelper Addon and got the Videos in .flv format which plays fine in VLC. So, for what ever this is all worth. That's what happened with installing pygame on my system...

Don
Comment 4 David Timms 2010-10-17 04:49:12 EDT
(In reply to comment #3)
> I opened up the .swf file from within Krusader.
OK, so it's a problem with both gnome and kde (this bug) file managers.

Basically, both filemanagers are determining that vnc2swfplay is the 'best' choice for playback of an swf file. In fact pyvnc2swf can only playback .swf files created by pyvnc2swf recorder.

I had a few attempts at resolving this, but was unsuccessful, but should have a solution over the coming month.

> Here is the results from rpm -qi pygame...
> [root@fedora13-gatewaygt5408 don]# rpm -qi pygame
> package pygame is not installed
Given that the spec defines:
Requires: pygame
, it seems that something was slightly screwy with the packages on the reporter's machine. It would be useful to see what went wrong:
1. as root # grep -E 'pygame|pyvnc2swf' /var/log/yum.log*
, to list out when updates/install/remove was made to the packages.

2. Does yum-complete-transaction indicate there is unfinished transactions ?

3. Does package-cleanup --problems list any issues ?
Comment 5 dweb98 2010-12-12 10:24:26 EST
Hi, sorry I still haven't been able to run those commands and get back with you on this. When I got this request for more info. I had already taken that HD out of the System it was in and Put it in another Computer. I had a problem with configuring grub to boot it in the new Box and still have not got back to it. Even if it would boot in the new Box, I don't know what effect that would have on the results, probably none though. I thought I might just put the HD back in the original Box and run those commands, but just have been too busy with other Systems.

Sorry,

Don
Comment 6 Bug Zapper 2011-06-01 10:22:21 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2011-06-29 09:47:12 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.