Bug 612792 - RFE: UI field to show list of bugs that have been cloned from a bug
RFE: UI field to show list of bugs that have been cloned from a bug
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.6
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 22:56 EDT by Perry Myers
Modified: 2014-10-12 18:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.4-3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 07:04:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2010-07-08 22:56:41 EDT
Description of problem:

When cloning a bug from one product to another, the cloned bug will have
set "Clone Of: foo" where foo is the original bug.

This provides a nice way to link back to the original bug.

But there's no way to look at the original and see the set of bugs that
were cloned from it unless you abuse the depends on/blocks fields.

case in point:
https://bugzilla.redhat.com/show_bug.cgi?id=611129
https://bugzilla.redhat.com/show_bug.cgi?id=605313 

Perhaps a text field next to "Clone Of" called "Clones" that just lists all of the bzs that are direct clones of this bug.  It would be nice if this list was hyperlinks similar to the depends on/blocks lists.
Comment 1 Jeff Fearn 2012-05-30 00:43:33 EDT
As part of the recent Bugzilla 4.2 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.
Comment 2 Jeff Fearn 2012-05-30 00:44:20 EDT
As part of the recent Bugzilla 2.4 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.
Comment 3 Perry Myers 2012-05-30 08:24:29 EDT
This has not been resolved with the latest bugzilla upgrade so it is still relevant.
Comment 4 Simon Green 2012-10-10 22:41:57 EDT
Bugzilla 4.2 custom fields can have reverse relationships. We should use this if possible. The one downside is that the custom field name will need to change, but that isn't a major issue.

An script will need to be written to migrate the existing values into the new custom field.

Tagging for 4.4 because of the invasive nature of the change.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.