Bug 612819 - Clean_ids should retain the chapter name in the id
Clean_ids should retain the chapter name in the id
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-09 02:56 EDT by BenC
Modified: 2010-11-23 23:18 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-29 20:39:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description BenC 2010-07-09 02:56:17 EDT
Description of problem:
When publican Clean_ids is run it truncates section ids with the result id=Book_Name-section_Name. For some book, this causes a clash (duplication) of ids resulting in an inability to build the book.

Version-Release number of selected component (if applicable):
version=2.1

How reproducible:
When section names are identical across book chapters    

Steps to Reproduce:
1. create a book with the same section name in two separate chapters:
 Introduction
    Other relevant resources on the topic
 Using TestNG project
    Other relevant resources on the topic
2. run publican Clean_ids
  
Actual results:
The build fails

Expected results:
The build succeeds

Additional info:
Retaining the chapter name in the truncated section ids will minimise the possibility of id clashes (duplication).
Comment 1 Ruediger Landmann 2010-08-19 01:51:22 EDT
There's only so much clean_ids can do; I've added the following warning to the Publican User Guide:

================
Important — ID conflicts can occur

The clean_ids command is intended to facilitate building a DocBook structure around documents ported from other formats such as HTML. However, clean_ids is file-based and and only has access to information in the XML file that it is currently processing and to the document name. Therefore, nodes of the same type that have the same title receive the same IDs. These duplicate IDs will prevent the document from building.

Use the clean_ids command to assist you in laying out your document, but expect that some manual adjustment to IDs might be necessary. We recommend that you do not run clean_ids on an already well established document.

================
Comment 2 Ruediger Landmann 2010-08-29 20:39:26 EDT
Since this is outside the scope of how clean_ids should work, closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.