Bug 61284 - gcc 2.96 can't compile qt3 rpm
gcc 2.96 can't compile qt3 rpm
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: qt3 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-15 17:59 EST by Jerry Quinn
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-15 17:59:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry Quinn 2002-03-15 17:59:20 EST
Description of Problem:

I'm trying to use the rawhide qt3 rpm to build qt3 for RH7.2 (can't find it
anywhere else).  The main bug is in gcc (I'll file a separate bug there), but
the qt3 config could be modified to avoid this.

gcc (2.96-98 and 2.96-106) consumes all memory trying to compile
qmake/generators/makefile.cpp during configure.  Basically the gcc optimizer
blows up.  The default qt build doesn't optimize when building qmake and has
no trouble completing.

Version-Release number of selected component (if applicable):

qt3-3.0.2-1.src.rpm

How Reproducible:

rpmbuild --rebuild qt3-3.0.2-1.src.rpm on a RH7.2 system

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Bernhard Rosenkraenzer 2002-03-18 08:39:08 EST
The qt3 package is obsolete and shouldn't be used. 
It's successor is the qt package, which works with 2.96. 
 
The reason for patching in -O2 is gcc 3.1: it miscompiles qmake if it's built without 
optimizations. 
 
The current qt package checks the compiler version and then applies the patch if gcc is 
>= 3.0.4 

Note You need to log in before you can comment on or make changes to this bug.