Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 612850 - dependency issue, perl(DBD::Oracle)
dependency issue, perl(DBD::Oracle)
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
1.1
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
: Regression
Depends On:
Blocks: space11
  Show dependency treegraph
 
Reported: 2010-07-09 04:45 EDT by Petr Sklenar
Modified: 2010-08-19 04:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 04:24:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2010-07-09 04:45:06 EDT
Description of problem:
dependency issue, perl(DBD::Oracle)

Version-Release number of selected component (if applicable):
spacewalk nightly

How reproducible:
always with spacewalk nightly

Steps to Reproduce:
1. have a fedora13 with all necessary spacewalk repo
2. yum install spacewalk-oracle
  
Actual results:
--> Processing Dependency: nutch for package: spacewalk-doc-indexes-1.1.1-1.fc13.noarch
---> Package spacewalk-oracle.noarch 0:1.1.3-1.fc13 set to be updated
--> Processing Dependency: perl(DBD::Oracle) for package: spacewalk-oracle-1.1.3-1.fc13.noarch
--> Processing Dependency: cx_Oracle for package: spacewalk-oracle-1.1.3-1.fc13.noarch
--> Finished Dependency Resolution
Error: Package: spacewalk-backend-sql-oracle-1.1.29-1.fc13.noarch (spacewalk-nightly)
           Requires: python(:DBAPI:oracle)
Error: Package: spacewalk-oracle-1.1.3-1.fc13.noarch (spacewalk-nightly)
           Requires: cx_Oracle
Error: Package: perl-NOCpulse-Probe-1.183.13-1.fc13.noarch (spacewalk-nightly)
           Requires: perl(DBD::Oracle)
Error: Package: spacewalk-backend-server-1.1.29-1.fc13.noarch (spacewalk-nightly)
           Requires: PyPAM
Error: Package: spacewalk-backend-sql-postgresql-1.1.29-1.fc13.noarch (spacewalk-nightly)
           Requires: python-pgsql
Error: Package: spacewalk-backend-tools-1.1.29-1.fc13.noarch (spacewalk-nightly)
           Requires: python-gzipstream
Error: Package: spacewalk-doc-indexes-1.1.1-1.fc13.noarch (spacewalk-nightly)
           Requires: nutch
Error: Package: spacewalk-base-minimal-1.1.4-1.fc13.noarch (spacewalk-nightly)
           Requires: perl(DBD::Oracle)
Error: Package: NPalert-1.126.11-1.fc13.noarch (spacewalk-nightly)
           Requires: perl(DBD::Oracle)
Error: Package: spacewalk-oracle-1.1.3-1.fc13.noarch (spacewalk-nightly)
           Requires: perl(DBD::Oracle)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
can install spacewalk-oracle

Additional info:
Comment 2 Jan Pazdziora 2010-07-09 05:38:25 EDT
Giving to Milan as he is the 1.1 release nanny.
Comment 6 Milan Zázrivec 2010-08-19 04:24:29 EDT
Spacewalk 1.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.