Bug 612861 - bnx2 page allocation failure
bnx2 page allocation failure
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-09 05:17 EDT by Albert Strasheim
Modified: 2010-07-13 15:31 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 13:39:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (121.41 KB, text/plain)
2010-07-09 05:17 EDT, Albert Strasheim
no flags Details
Proposed fix. (2.87 KB, text/plain)
2010-07-10 09:27 EDT, Stanislaw Gruszka
no flags Details

  None (edit)
Description Albert Strasheim 2010-07-09 05:17:34 EDT
Created attachment 430579 [details]
/var/log/messages

Description of problem:

I was bringing up a bnx2 interface (eth2) on a Dell M610 while receiving data on another bnx2 interface (eth0) at about 20 MB/s.

I had the following error from the kernel in /var/log/messages:

page allocation failure. order:0, mode:0x20

Version-Release number of selected component (if applicable):

kernel-2.6.33.3-85.fc13.x86_64

How reproducible:

ifup a few bnx2 interfaces while receiving data

Additional info:

/var/log/messages attached
Comment 1 Stanislaw Gruszka 2010-07-10 09:27:59 EDT
Created attachment 430878 [details]
Proposed fix.

Are you able to test this patch?
Comment 2 Albert Strasheim 2010-07-13 04:38:35 EDT
Thanks for the patch. I can test it, but so far I have been unable to reproduce the allocation failure on the unpatched kernel. Do you have any idea what I need to do to see the allocation failure again on the unpatched kernel before I try the patch?
Comment 3 Stanislaw Gruszka 2010-07-13 13:39:45 EDT
(In reply to comment #2)
> Do you have any idea what I
> need to do to see the allocation failure again on the unpatched kernel before I
> try the patch?    

No. I saw a few memory allocation failures in random places and there was no working steps to reproduce to any of them :(

Since this is issue is not reproducible, I will only post patch upstream, without applying it to fedora kernel.

Thanks for reporting.

Note You need to log in before you can comment on or make changes to this bug.