Bug 61291 - __libc_wait(GLIBC_2.0) fails to resolve.
Summary: __libc_wait(GLIBC_2.0) fails to resolve.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-16 03:36 UTC by Sam Varshavchik
Modified: 2016-11-24 15:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-16 03:36:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sam Varshavchik 2002-03-16 03:36:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020202

Description of problem:
/lib/i686/libpthread.so.0 defines the __libc_wait@@GLIBC_2.0 symbol in glibc
2.2.4 on Red Hat 7.2

glibc 2.2.5 no longer defines this symbol in /lib/i686/libpthread.so.

Looks like this breaks Java.

Sun's Java2 SDK runs fine on 7.2 with glibc 2.2.4, but apparently doesn't like
glibc 2.2.5 :-(

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Sun's JAVA2 SDK.
2. Try Do anything, such as:

$ cat >x.java
class x {
}
$ javac x.java



Actual Results:

Error occurred during initialization of VM
Unable to load native library: /usr/libexec/java2/jre/lib/i386/libjava.so:
symbol __libc_wait, version GLIBC_2.0 not defined in file libc.so.6 with link
time reference


Additional info:

Although the error message refers to libc.so.6, looking at the strace shows
libpthread being opened last before everything bombs out.

Comment 1 Jakub Jelinek 2002-03-17 19:14:17 UTC
Sun has no business using glibc private symbols (especially when they are so
promoting ABIcheck).
In glibc-2.2.5-27 I've temporarily exported it again, but in 2.3 it will be
gone for good.

Comment 2 Preston Brown 2002-04-10 18:18:34 UTC
Jakub:

Can you please try and get this message to the Sunsoft people directly?


Note You need to log in before you can comment on or make changes to this bug.