Bug 61293 - HTTP error codes ignored in installation
HTTP error codes ignored in installation
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-16 07:48 EST by Andrew Bartlett
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 16:41:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Bartlett 2002-03-16 07:48:21 EST
Description of Problem:
Anaconda doesn't deal with HTTP errors correctly.

Version-Release number of selected component (if applicable):



How Reproducible:

On demand, every time.

Steps to Reproduce:
Setup a HTTP server with loopback ISO mounts.  Create a common directory, and
symbolic links to files from each CD.  For this to work you need to create a
'RedHat' dir, with an RPMS subdir (containing symlinks to all the files). 

I tried to do this, but botched it up, and ended up with RedHat being a link to
just cd1's copy.  This caused 404 errors in the HTTP installation (becouse cd2's
files were not there).  This was not picked up by the installer, excpet that the
2nd half of the install took only 5 seconds :-).

This was for an upgrde from RH 6.2, if that matters, using the network boot
image from http://redhat.com/support/errata/RHBA-2002-016.html

Actual Results:

Installation (upgrade) compleats 'successfully', but some applications get
shared lib errors due to version conflicts.

Expected Results:

A normal installtaion, with all expected RPMS.

Additional Information:

I also got some dependency issues that I had to resolve manually when I added
the extra packages (I got the list by looking in the server's error log), so
check that all the places that call this check the return.

Remember, there are a lot of good reasons a HTTP download could fail, the user
should be given a chance to bail or retry.

Andrew Bartlett
Comment 1 Jeremy Katz 2002-03-26 16:41:33 EST
Fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.