Bug 61297 - Kickstart installation fails to grow partition to end of disk
Kickstart installation fails to grow partition to end of disk
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-16 12:03 EST by Roel Teuwen
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-18 18:09:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roel Teuwen 2002-03-16 12:03:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
When using a kickstart floppy containing the following partition definitions :
part /boot --size 128
part swap --size 1024 --grow --maxsize 2048
part /usr --size 4096
part /var --size 1024 --grow --maxsize 2048
part /tmp --size 1024 --grow --maxsize 2048
part / --size 1024 --grow

The / partition does NOT fill up the entire disk ! on a 40GB disk, about 50%
remains unallocated. On a 16GB disk, about 3GB is left unused.

setting as primary partition, or defining a higher --size as minimal siwe
doesn't help.
workaround is to define a maxsize for / of 9999999999 or so.


Version-Release number of selected component (if applicable): 7.1


How reproducible:
Always

Steps to Reproduce:
1. create ks.cfg
2. copy to floppy
3. boot from cdrom and type "linux ks=floppy"
	

Actual Results:  installation completes successfully, but partition size of / is
incorrect.

Expected Results:  / should have grown to use the space left over after other
partitions reached the maxsize.
Comment 1 Jeremy Katz 2002-03-18 15:08:24 EST
I haven't seen this one in any of my kickstart installs and I regularly do
similar things.  msf, have you seen this on your runs with the ksrobot?
Comment 2 Roel Teuwen 2002-03-18 18:09:02 EST
It is easy to reproduce using the exact settings as defined above.
The remaining unused percentages is a function of the disk size. The bigger the
disk, the larger the unused size.
About the same problem occurs on a system with multiple disks. I hqve not tested
if putting / on a disk by itself makes a difference.
Comment 3 Jeremy Katz 2002-04-08 19:28:53 EDT
This has worked just fine for me on a number of installs and I can't reproduce
the problem.
Comment 4 Roel Teuwen 2002-04-09 14:33:00 EDT
Too bad you cannot reproduce the problem. I have had this issue on all machines
so far, except on disks below a certain size. The problem seems to occur only
when the disk size or the total size of disks combined is 15GB or so, or higher.

I have verified that this problem is not present in 7.2 and 7.3beta
(Enigma/Skipjack)

The workaround works a treat, though

Note You need to log in before you can comment on or make changes to this bug.