Bug 613107 - fatal: assertion "gfs_glock_is_locked_by_me(gl) && gfs_glock_is_held_excl(gl)" failed
Summary: fatal: assertion "gfs_glock_is_locked_by_me(gl) && gfs_glock_is_held_excl(gl)...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-kmod   
(Show other bugs)
Version: 5.2
Hardware: i386 Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Abhijith Das
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords: ZStream
: 612624 (view as bug list)
Depends On: 471258
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-09 17:54 UTC by Benjamin Kahn
Modified: 2013-01-11 03:07 UTC (History)
12 users (show)

Fixed In Version: kmod-gfs-0.1.34-2.el5_4.4
Doc Type: Bug Fix
Doc Text:
When SELinux was in permissive mode, a race condition during file creation was able to cause one or more cluster nodes to be fenced and lock the remaining nodes out of the GFS file system. This race condition no longer occurs with this update.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-04 15:12:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0598 normal SHIPPED_LIVE gfs-kmod bug-fix update 2010-08-04 15:12:32 UTC

Description Benjamin Kahn 2010-07-09 17:54:00 UTC
This bug has been copied from bug #471258 and has been proposed
to be backported to 5.4 z-stream (EUS).

Comment 3 Lon Hohberger 2010-07-09 17:54:47 UTC
*** Bug 612624 has been marked as a duplicate of this bug. ***

Comment 4 Abhijith Das 2010-07-12 16:57:01 UTC
5.4.z build with patch included is here:
http://download.devel.redhat.com/brewroot/packages/gfs-kmod/0.1.34/2.el5_4.4

Comment 6 Florian Nadge 2010-07-13 12:41:05 UTC
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
When SELinux was in permissive mode, a race condition during file creation was able to cause one or more cluster nodes to be fenced and lock the remaining nodes out of the GFS file system. This race condition no longer occurs with this update.

Comment 9 errata-xmlrpc 2010-08-04 15:12:35 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0598.html


Note You need to log in before you can comment on or make changes to this bug.