Bug 61311 - Anaconda Terminates with Signal 11
Anaconda Terminates with Signal 11
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-17 01:18 EST by Clay Jackson
Modified: 2007-04-18 12:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-01 11:49:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clay Jackson 2002-03-17 01:18:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90; Q312461)

Description of problem:
Anaconda terminates with Sig 11 after being unable to probe video or monitor

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot my FIC 503+ motherboard with an AMD-K6/2 266, VIA chipset, 96M of memory.
2. choose EITHER linux text or linux updates text
3.
	

Actual Results:  Anaconda terminates after saying "Unable to probe video" 
and "Unable to probe Monitor"
Updates had no effect
I also tried "noathlon"


Expected Results:  Install RH 7.2

Additional info:

RedHat 7.1 installs and runs just fine
Comment 1 Clay Jackson 2002-03-17 12:48:55 EST
FYI - based on earlier bugs/comments, I have verified the MD5 Sums on both CDS 
and the update disk, and they're good.
Comment 2 Jeremy Katz 2002-03-18 15:09:50 EST
What type of video hardware?
Comment 3 Clay Jackson 2002-03-18 23:38:17 EST
OK - the video WAS an old style (not PCI) Trident board.  Replaced that with an 
ATI Mach 64 VT PCI board and it now (correctly) DETECTS the video board AND the 
monitor, but still segmentation faults at the same spot when the updates are 
NOT applied.  HOWEVER, if I apply the update disk (again, MD5 verified), I 
get 'anaconda line 5 50 segmentation fault' (instead of just 'Signal 11 
Segmentation fault').  

Also, FWIW, there IS an AGP slot on the motherboard; I just don't happen to 
have a spare AGP card floating around.   

Clay
Comment 4 Michael Fulbright 2002-03-27 14:28:10 EST
What are the last few lines of output on VC3 and VC4 (cntl-alt-f3 and -f4) when
the critical error occurs?
Comment 5 Clay Jackson 2002-03-27 22:05:22 EST
VC3 is:
found suggestion of agpgart
.
.
.
looking for video cards requiring agpgart module
found video card controller unknown
.
. <bunch of insmods all NULL>
.

going to insmod reiserfs.o (path is NULL)
looking for USB mouse

VC4 is:
md: raid5 personality registered as nr 4
journalled block device driver loaded

Comment 6 Michael Fulbright 2002-04-09 14:30:34 EDT
Any ideas Jeremy?
Comment 7 Jeremy Katz 2002-04-09 16:06:03 EDT
Does your hardware pass memtest86 (http://www.teresaudio.com/memtest86/)?
Comment 8 Clay Jackson 2002-04-10 01:56:16 EDT
Yep - just passed 3 passes of the standard test..
Comment 9 Michael Fulbright 2002-04-15 17:11:35 EDT
This still seems to be a hardware issue, we have not had this occur on a variety
of hardware.

Comment 10 Clay Jackson 2002-04-15 17:27:08 EDT
OK - have you specifically tried this on a system:

1)  With an AMD CPU
2)  With AGP Graphics Support
3)  WITHOUT an AGP Graphics card installed

I'm trying to determine if buying an AGP card might solve my problem.

Thanks!
Comment 11 Michael Fulbright 2002-04-16 16:34:43 EDT
We do not have a FIC 503+ motherboard, so I can't speculate on what might be
casuing the problem.  I'm not saying there isn't a problem, but it is not
something we can fix because there are just too many varieties of hardware. If
you can borrow a different video card and try it out it could act differently.
Comment 12 Clay Jackson 2002-04-20 00:20:02 EDT
OK - I picked up an AGP video board, and that seems to have made no 
difference.  Any thoughts as to what hardware issues might be causing this 
would be appreciated.  Also, what would happen if I just applied all of the new 
RPMS w/o actually running through anaconda?

Thanks!
Comment 13 Michael Fulbright 2002-05-01 11:49:25 EDT
Could you try using a different CD drive?  This is the first report of a problem
like this in several thousand bugs, so its difficult to diagnose.
Comment 14 Clay Jackson 2002-05-23 01:28:22 EDT
Just installed 7.3 on the exact same box, and it works great!  So, whatever 
happened in 7.2 is fixed....

Thanks!

Clay

Note You need to log in before you can comment on or make changes to this bug.