Bug 613135 - reduced functionality
reduced functionality
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-09 15:38 EDT by mike simpson
Modified: 2010-07-13 08:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-09 16:29:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mike simpson 2010-07-09 15:38:12 EDT
Attempting to install RHEL6 i386-workstation-beta2 on laptop with 3 partitions already present on disc:
1x vfat (latitude on reader partition - which i wish to keep)
2x ntfs (windows 7 partitions)
Unable to select the ntfs partitions to use for RHEL6 without using manual partition selection.
Unable to use automatic partition method without losing the vfat partition.
This is a significant decrease in functionality compared to previous anaconda installs in both RHEL and Fedora.
At present i would need to use fedora 13 anaconda (or other partition manager iso) to wipe the ntfs partitions in order to then use the auto-partition option for RHEL 6 anaconda. Seems a bit non-userfriendly considering that a large amount of new computers (with windows preinstalled) come with "rescue" or "diagnostic" partitions which sysadmins may wish to keep whilst getting rid of the main windows partition.

mike
Comment 2 David Cantrell 2010-07-09 16:29:13 EDT
Unfortunately, in this particular case, Fedora will offer more partitioning flexibility than RHEL simply because RHEL is shipping without NTFS support.  When installing RHEL, you will need to make sure there is some unpartitioned space on the target disk in order for the auto partitioning to work, otherwise you will have to go with manual partitioning.
Comment 3 mike simpson 2010-07-10 04:48:11 EDT
Thank you for youe reply.
Not quite sure why not having ntfs support should make any difference in being able to properly edit the partition table at that stage in anaconda. Are you really saying that RHEL has to be able to read the data *inside* the partitions in order to be able to delete them as part of a "choose an area of the disc to install RHEL6 on" auto install? I would have thought that NTFS support wouldn't have any impact on RHEL's ability to interact with the partition table. Please explain?

mike
Comment 4 David Cantrell 2010-07-12 17:34:02 EDT
We don't read the data inside the partition, but to accurately detect it as NTFS, we need ntfsprogs.  ntfsprogs is not part of RHEL, unfortunately.  Specifically, we need the ntfsinfo command and ntfsresize to implement the functionality you were describing.  It's down to a policy decision rather than a technical decision.  Without the tools, we [anaconda] cannot offer the functionality you describe.  Red Hat has made the decision to not ship ntfsprogs as part of RHEL, therefore anaconda will have NTFS support disabled.
Comment 5 mike simpson 2010-07-13 08:43:07 EDT
That makes sense. Thank you for taking the time explaining it to me.

mike

Note You need to log in before you can comment on or make changes to this bug.