Bug 613280 - SELinux is preventing /usr/bin/python "read" access on yum.pid.
SELinux is preventing /usr/bin/python "read" access on yum.pid.
Status: CLOSED DUPLICATE of bug 612327
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:d748c0856fc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-10 08:29 EDT by John Margaritopoulos
Modified: 2011-01-05 04:14 EST (History)
36 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 05:26:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Margaritopoulos 2010-07-10 08:29:08 EDT
Summary:

SELinux is preventing /usr/bin/python "read" access on yum.pid.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by yum. It is not expected that this access is
required by yum and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:initrc_var_run_t:s0
Target Objects                yum.pid [ file ]
Source                        yum
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.6.4-27.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-33.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.33.5-124.fc13.i686.PAE #1 SMP Fri Jun 11
                              09:42:24 UTC 2010 i686 i686
Alert Count                   4
First Seen                    Sat 10 Jul 2010 03:26:18 PM EEST
Last Seen                     Sat 10 Jul 2010 03:26:36 PM EEST
Local ID                      bf2e5692-dc43-4a64-873c-90487a6ca874
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1278764796.952:222): avc:  denied  { read } for  pid=5815 comm="yum" name="yum.pid" dev=sda3 ino=264603 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_var_run_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1278764796.952:222): avc:  denied  { open } for  pid=5815 comm="yum" name="yum.pid" dev=sda3 ino=264603 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_var_run_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1278764796.952:222): arch=40000003 syscall=5 success=yes exit=10 a0=93f92e0 a1=8000 a2=1b6 a3=9408bf9 items=0 ppid=5814 pid=5815 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="yum" exe="/usr/bin/python" subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,yum,abrt_t,initrc_var_run_t,file,read
audit2allow suggests:

#============= abrt_t ==============
allow abrt_t initrc_var_run_t:file { read open };
Comment 1 Miroslav Grepl 2010-07-12 05:26:35 EDT

*** This bug has been marked as a duplicate of bug 612327 ***
Comment 2 gar sau 2010-11-17 11:39:09 EST
not sure im a new user

Note You need to log in before you can comment on or make changes to this bug.