Bug 613400 - abrt doesn't want me to report a bug
abrt doesn't want me to report a bug
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-11 06:38 EDT by Sjoerd Mullender
Modified: 2015-02-01 17:52 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 08:24:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sjoerd Mullender 2010-07-11 06:38:57 EDT
Description of problem:
I got a crash in f-spot, so I tried reporting it with abrt.  I filled in the requested information, writing information about what I did and what happened.
Then I noticed that I couldn't send the report. The tool told me at the bottom of the screen that I should run "debuginfo-install mono-core" and use the Refresh button.  I did that, and then abrt refreshed the window *loosing all my text*.
Also, it still says that I should run "debuginfo-install mono-core", even though that is now installed.

The exact text at the bottom of the window is:
Please fix the following problems
* Reporting disabled because the backtrace is unusable.
Please try to install debuginfo manually using command: debuginfo-install mono-core then use Refresh button to regenerate the backtrace.

Version-Release number of selected component (if applicable):
abrt-1.1.1-1.fc13.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Get f-spot to crash and click on abrt icon in taskbar
2.Fill in details about the crash
3.Run debuginfo-install mono-core as requested
4.Hit Refresh button
  
Actual results:
After hitting the Refresh button, the bug report is generated afresh, and all information that was typed in in step 2 is lost.  Also, the remark about installing the debuginfo for mono-core is still there and the Send report button is still grayed out (even after checking the checkmark for sensitive data).

Expected results:
The text I typed in step 2 above should be kept in tact and the Send report button should be enabled.

Additional info:
I am now unable to report the crash in f-spot.
Comment 1 Jiri Moskovcak 2010-08-03 08:24:53 EDT
> Expected results:
> The text I typed in step 2 above should be kept in tact

this should be already fixed in git.

> and the Send report
> button should be enabled.
>

unfortunately the mono crashes are quite specific and ABRT doens't handle them well (yet) so that's why mono-core has been blacklisted and since 1.1.1-2 ABRT shouldn't report these crashes.

Thank you for the report, hopefully we will improve the handling of mono crashes and re-enabled it soon.

Jirka

Note You need to log in before you can comment on or make changes to this bug.