Bug 613426 - debuginfo packages fail to install on rawhide
debuginfo packages fail to install on rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Denys Vlasenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-11 09:51 EDT by Rudolf Kastl
Modified: 2011-04-26 12:19 EDT (History)
9 users (show)

See Also:
Fixed In Version: abrt-2.0.1-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-26 12:19:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file from abrtd (121.78 KB, application/octet-stream)
2010-07-13 11:49 EDT, Rudolf Kastl
no flags Details
tarball of the /var/run/abrt-tmp dir (8.40 KB, application/x-bzip2)
2010-07-13 11:50 EDT, Rudolf Kastl
no flags Details
abrt-ccpp (1.92 MB, application/x-bzip2)
2010-07-13 14:15 EDT, Rudolf Kastl
no flags Details

  None (edit)
Description Rudolf Kastl 2010-07-11 09:51:29 EDT
Description of problem:
debuginfo packages fail to install on rawhide with arbt-gui

Version-Release number of selected component (if applicable):
abrt-1.1.5-1.fc14.x86_64

How reproducible:
always

Steps to Reproduce:
1. start nautilus on rawihde and watch it segfault or use debugmode and watch like everything crash
2. startup abrt-gui
3. let it try to install debuginfo packages
4. -vvv output:

abrt-gui: Update:Starting debuginfo installation
abrt-gui: Update:Getting list of build IDs
abrt-gui: Update:126 missing debuginfos, getting package list from cache
abrt-gui: Update:126 missing debuginfos, getting package list from repositories
abrt-gui: Update:126 debuginfos can't be found
abrt-gui: Update:Generating backtrace

  
Actual results:
no debuginfos installed

Expected results:
debuginfos installed

Additional info:
manual install with debuginfo-install nautilus works.
Comment 1 Rudolf Kastl 2010-07-13 11:49:36 EDT
Created attachment 431498 [details]
log file from abrtd
Comment 2 Rudolf Kastl 2010-07-13 11:50:31 EDT
Created attachment 431499 [details]
tarball of the /var/run/abrt-tmp dir
Comment 3 Denys Vlasenko 2010-07-13 13:30:22 EDT
Can you also attach the tarball of /var/spool/abrt/ccpp-1278854454-584 directory?
Comment 4 Rudolf Kastl 2010-07-13 14:15:53 EDT
Created attachment 431544 [details]
abrt-ccpp
Comment 5 Denys Vlasenko 2010-07-13 14:40:17 EDT
abrt-debuginfo-install executes a LONG "yum provides" command in order to figure out which packages are needed. I just tested it on my machine and it works: it prints a lot of items like this:

e2fsprogs-debuginfo-1.41.12-3.fc14.x86_64 : Debug information for package e2fsprogs
Repo        : rawhide-debuginfo
Matched from:
Filename    : /usr/lib/debug/.build-id/ed/b218708904a698add3bcb390487e21bccc1244.debug


Apparently your yum repo setup is broken. yum_provides.1.OUT from abrt-debuginfo-install contains:

This system is not registered with RHN.
RHN support will be disabled.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora-debuginfo. Please verify its path and try again
yum exitcode:0

and yum_provides.2.OUT contains:

This system is not registered with RHN.
RHN support will be disabled.
Cannot find a valid baseurl for repo: rpmfusion-free-debuginfo
yum exitcode:0


Please fix this problem. To check that it works, run the following on your machine (it's a one line, 9000+ chars long command):

yum  '--disablerepo=*' '--enablerepo=*-debug*' --showduplicates --quiet provides /usr/lib/debug/.build-id/01/06e864cb9eb212aae30dc89c00869a279f9f8c.debug /usr/lib/debug/.build-id/02/a4d2cafaa326baa81000e30afb8cdda8bcb892.debug /usr/lib/debug/.build-id/06/d8d77becfb4505090aa9cd5b84d09510f8512a.debug /usr/lib/debug/.build-id/08/dbf498ef51240ba3a2d7c4d8014058f61b3f3a.debug /usr/lib/debug/.build-id/09/7ec0b55136af3e3f6beccc25075fa51aa86692.debug /usr/lib/debug/.build-id/0c/225819f9b06419d2a4d0ea0b16e129f882b76d.debug /usr/lib/debug/.build-id/0d/5235e3f7ef8ef66fb12cb041161d8022f87247.debug /usr/lib/debug/.build-id/10/dae7a868532292ccd7e8b5bcc93453f91d04a2.debug /usr/lib/debug/.build-id/12/f5c20d05d4bd77073430b89bf67e26704f0134.debug /usr/lib/debug/.build-id/14/4b8d2c204b77a58ebaf8ad290af54d4e9bc442.debug /usr/lib/debug/.build-id/14/62fd5255dbd72e713c6f8a085163e881d37d31.debug /usr/lib/debug/.build-id/14/b4ce8286a639e6682a4732f6b33a4ff08895e3.debug /usr/lib/debug/.build-id/14/d898fb2cc05c91f5b9a1a2d575f08f33ed12aa.debug /usr/lib/debug/.build-id/16/660ae210f58d5363f24408aa4424ab93b1827e.debug /usr/lib/debug/.build-id/18/7bdd94556a9df45b61cc19429fca097ca65c74.debug /usr/lib/debug/.build-id/19/b4a36778d6fd1129cae01f6547ffc0460159a1.debug /usr/lib/debug/.build-id/1a/c7a04dbcb1dcc630a9093b31462a9906ff7bd4.debug /usr/lib/debug/.build-id/1b/0000b1bdd8dea5ddf5c1d094ce40a4dfb19ceb.debug /usr/lib/debug/.build-id/1e/611b9ca37125b801e9a802e44a3940bf6ab1d4.debug /usr/lib/debug/.build-id/23/1d342dda9689198e218e18de1022227b2fe0ac.debug /usr/lib/debug/.build-id/28/77a751dc0fb6753b964a252bec220fdcf1a01b.debug /usr/lib/debug/.build-id/29/06864a3198da7764c9ca239e917230a62425b4.debug /usr/lib/debug/.build-id/2f/99a40e3d893f5e24b9ab32f0d41ed83aba3aaa.debug /usr/lib/debug/.build-id/34/a688519e05597e77f7629acd1edc674404cf9d.debug /usr/lib/debug/.build-id/35/57ffe0c46ce5566e8051142fed4dd582d82234.debug /usr/lib/debug/.build-id/38/ad0688e29f594682cb4a85beeaaa4c1d53cd17.debug /usr/lib/debug/.build-id/39/a5eebc8182361dda2c12850acd71065bb1d605.debug /usr/lib/debug/.build-id/3a/b0e27bd7eb9028ddf8196dcb6dd6710b2bf32a.debug /usr/lib/debug/.build-id/3c/c571be2764ff64be2a285533b9944e38fecd0b.debug /usr/lib/debug/.build-id/3e/1073caf4178fa979a64f16c601bb90b0a4aaaf.debug /usr/lib/debug/.build-id/40/eea834d3dc566d35fbb07f7976d0caa2023e80.debug /usr/lib/debug/.build-id/42/fee5e5f4a1023a83b7723be8aca9f10ef82c34.debug /usr/lib/debug/.build-id/43/4a16ffa2c70c0283919a2d362e14e6352a6265.debug /usr/lib/debug/.build-id/46/aa80b0f80904cf76f07db72de83958fb3aaa37.debug /usr/lib/debug/.build-id/47/faba7f75096713ee778b67c904ee41d6df4a95.debug /usr/lib/debug/.build-id/49/1241ab861b7f11dcb03aa5ef96847f181d055d.debug /usr/lib/debug/.build-id/49/21cc7e9abe91306463ca172ad3fc4083a63bdd.debug /usr/lib/debug/.build-id/49/d03666993f7d43ff5d6abcdce89a0ea9d2e510.debug /usr/lib/debug/.build-id/4b/03eb1beefd888a93372e89f56e66da5417fc19.debug /usr/lib/debug/.build-id/50/5fcb24cc2599a63f4aafc5053b55c42b875453.debug /usr/lib/debug/.build-id/50/fbcce5bfe987573e759220d19cbb4c43028406.debug /usr/lib/debug/.build-id/54/34c32456048103c3bae69bfdf039541e423df5.debug /usr/lib/debug/.build-id/55/05c483091059d5176618fee9d486aee9e52332.debug /usr/lib/debug/.build-id/57/c28d8acc98406d9963001f717508bb3064a09a.debug /usr/lib/debug/.build-id/5f/a839fff8609db3df19adbc8d557d923619775a.debug /usr/lib/debug/.build-id/64/4e80d8e97b2e0685867d0c8ecf230f5f734c28.debug /usr/lib/debug/.build-id/65/346460679f84e1c0ac6abc17c93ee712b7e31c.debug /usr/lib/debug/.build-id/6a/20b4e69372431eef52dea8e83d61cf7465defd.debug /usr/lib/debug/.build-id/6a/b2d4b409e198d0340f72caeb141f1192b3e1aa.debug /usr/lib/debug/.build-id/6a/cd2a637f5d6b5b00b84f3a8357057c6349a163.debug /usr/lib/debug/.build-id/6d/b8c31d0abec1d26e6535afed90782edf478734.debug /usr/lib/debug/.build-id/6e/4f97581f1c498e2ff220c628683793b04b34fa.debug /usr/lib/debug/.build-id/71/9cac729700256be87d4f19af7e92e303fb1514.debug /usr/lib/debug/.build-id/72/1242ecc3448d07f4eef06b52cd065d2dfebe96.debug /usr/lib/debug/.build-id/72/6567f9f7e9db5353816ed1b9d8ce0719e1ef8c.debug /usr/lib/debug/.build-id/75/60653f6eeff60b8921a0ec59ceb4f29da60af5.debug /usr/lib/debug/.build-id/76/3640eb08fb7e7c137896d359a7a95071991ec9.debug /usr/lib/debug/.build-id/77/9d3a90a155d9ac71c55a75a808803aca270b1d.debug /usr/lib/debug/.build-id/79/f06ff163a159883847ca368da8f4931ed243ad.debug /usr/lib/debug/.build-id/7a/406c9c21447ead8372ccf7b3b1f444255e068c.debug /usr/lib/debug/.build-id/7d/24046e7a4cbb0550fc75a470cdf505c6d01e90.debug /usr/lib/debug/.build-id/7d/49b4907903446947aa79f5c829648919785472.debug /usr/lib/debug/.build-id/7e/22e291fab08ab667fa1afa7772691f5ed82afb.debug /usr/lib/debug/.build-id/7f/40975acb78d10d567cd22cf366620485b1bf60.debug /usr/lib/debug/.build-id/83/038894cd50d940d3f09dde9503389dbcace93d.debug /usr/lib/debug/.build-id/86/97e67e76d98371b06e3d43ec4bcff168f5a828.debug /usr/lib/debug/.build-id/87/e7980b62508a3521f93a2660acd8bdd0422242.debug /usr/lib/debug/.build-id/8c/20a9986b5692168b444ca92c1bba3cabe58563.debug /usr/lib/debug/.build-id/8c/88be05f83b1040939c3015add806df68a6591a.debug /usr/lib/debug/.build-id/8d/1cf70b5dd3034ef0d46a756054647bd62b9bd7.debug /usr/lib/debug/.build-id/8d/29777c99ce90b873c6f330fa75d161e5df2fcf.debug /usr/lib/debug/.build-id/8e/0ddeeb4926290a84c9141782d669fbdaea6712.debug /usr/lib/debug/.build-id/91/466fdaf6a8ae49f401ea96df6e4abf8a356b93.debug /usr/lib/debug/.build-id/92/893d68cc907a56f77ceeead40ad0bbe1604777.debug /usr/lib/debug/.build-id/95/eb0bce134beef3f76376375fe2e60a4179051d.debug /usr/lib/debug/.build-id/98/b846104b4649df3e29667860010c795203f207.debug /usr/lib/debug/.build-id/9e/b3646a4d95b88c0d8b57aa8b2a0ca01569cc6d.debug /usr/lib/debug/.build-id/9f/4517a11ba678dc1910393dea67e3f5d93afd3b.debug /usr/lib/debug/.build-id/a0/020abd556cf7647fbb86e0241e77df70847d78.debug /usr/lib/debug/.build-id/a4/38ba384206f43794b6c06d1921205b7fc918e0.debug /usr/lib/debug/.build-id/a8/2d9d47afb2bc49923a452861efe778eb99f913.debug /usr/lib/debug/.build-id/ab/c9e44fe48a2ef2a926d08dba68ae862aa5cc87.debug /usr/lib/debug/.build-id/ad/18bc40447fae5a38e1b415111ca0ad906b0b1b.debug /usr/lib/debug/.build-id/ad/dd9ae423c6afaeb323ed1ec9a1d5e83f4b2252.debug /usr/lib/debug/.build-id/af/2be6d3d74549c0b4854bf87ff675c0301e7d22.debug /usr/lib/debug/.build-id/b1/b7b68d8733f529f897a4b29dc0017fe08a147b.debug /usr/lib/debug/.build-id/b4/087a2fae97be94206178af1c8bbb5039077a83.debug /usr/lib/debug/.build-id/b4/49148035b7aa201f10a9051eba2febc936fc58.debug /usr/lib/debug/.build-id/b4/fa9dd745a9f04edde51417cae8561892dbe0b8.debug /usr/lib/debug/.build-id/b5/bc98c125a11b571cf4f2746268a6d3cfa95b68.debug /usr/lib/debug/.build-id/b8/39563a6fee9153ae543c19a3966a9c3088450b.debug /usr/lib/debug/.build-id/b8/6daa3d3edc24ba8df4d57b2c1ea16da676404e.debug /usr/lib/debug/.build-id/ba/092cc9a4502360316a6327d7de17a01bee1b16.debug /usr/lib/debug/.build-id/c3/ca48a6b9d0c56f25287d943711a5f82cb77a45.debug /usr/lib/debug/.build-id/c3/f5ceef79fe1834466631b29d6549cdc54fc1c8.debug /usr/lib/debug/.build-id/c6/99c7f0937e2b3e1d5bca64e82a17b4ffa67120.debug /usr/lib/debug/.build-id/c9/988994d0e4a17da7022b2ffdda31e9a7155cb6.debug /usr/lib/debug/.build-id/cb/ed7972dd04d01cf41e64c75a0a43c3288e244c.debug /usr/lib/debug/.build-id/cd/d93277e3ed861ad1cb4e6a0c3fb4d54e08def1.debug /usr/lib/debug/.build-id/ce/176829ef8a1a293d7d5f3879a52030509e03ea.debug /usr/lib/debug/.build-id/d0/6c3f74b0797b35ec4aab7f964c8cf2d7666edd.debug /usr/lib/debug/.build-id/d1/8fbd48178b626fe308ee864f632e231fcb2a1e.debug /usr/lib/debug/.build-id/d5/fddbf4e52805ba003bf3a314ee7bb179c7332f.debug /usr/lib/debug/.build-id/d7/b0d204688f126578d00fc42dc97e7c54bd9f79.debug /usr/lib/debug/.build-id/d7/fb4c4c90ce1bcccc8b90ba185248e558b8bb08.debug /usr/lib/debug/.build-id/d8/983c0cb2d8013030cdcc6a6a2ffff284835a4e.debug /usr/lib/debug/.build-id/d8/e56dfa428b6d630932dde52357bee071453170.debug /usr/lib/debug/.build-id/dc/9c1034fb7cbf0786b74cb5fd8f98ddf4341337.debug /usr/lib/debug/.build-id/df/696fc7465adbd15517ec5c0cc96021ba4ff833.debug /usr/lib/debug/.build-id/df/6cb55a69f28b84613a67b0085277c311c07850.debug /usr/lib/debug/.build-id/df/7fce0811f8a9ecbb49984cd8793a892e81669e.debug /usr/lib/debug/.build-id/e0/521cf5429b16a8124953dff0363bf6de02f3f1.debug /usr/lib/debug/.build-id/e0/ed0afbbe2ce160eb6351eed010bf5eaa89e514.debug /usr/lib/debug/.build-id/e3/7d508cd9f24ae2d9c8e92374018e88d1ee8763.debug /usr/lib/debug/.build-id/e5/c862fa3d4f3e35a292d05c55f82a5fdf590a2b.debug /usr/lib/debug/.build-id/ea/41bec7fea887033c7e17a03286d9f7fd37375f.debug /usr/lib/debug/.build-id/eb/6ff6d0579d641ea48c0271ccac0af9a26cfd33.debug /usr/lib/debug/.build-id/ed/4a02ea63baabcb568d887312cc36af34b91382.debug /usr/lib/debug/.build-id/ed/b218708904a698add3bcb390487e21bccc1244.debug /usr/lib/debug/.build-id/f1/ff6c8ee30dba27e90ef0c5b013df2833da2889.debug /usr/lib/debug/.build-id/f3/49ffbd341c7dc301023a9a9a788d242d38d9c9.debug /usr/lib/debug/.build-id/f8/e635dc279d7e5c1de9c221796c7a1ada2eff66.debug /usr/lib/debug/.build-id/f9/503a7616dd58a7fa129b2d97a6265e1a5a78d6.debug /usr/lib/debug/.build-id/f9/f208544b2862c62c3eed4272a88e27efef1d08.debug /usr/lib/debug/.build-id/fb/3b9b1013ba229d625702f7a352ab7210922fb3.debug /usr/lib/debug/.build-id/fb/a3fc2a1a119c391d9da0986f1ee90f61d4ea63.debug
Comment 6 Rudolf Kastl 2010-07-13 15:07:47 EDT
the actual problem seems to be that we blindly enable all *debuginfo channels in the abrt-debuginfo-install script.

if you use rawhide (with releasever 14) it will barf on those repo files that are meant for the stable releases because the mirrorlists and repos for releasever 14 dont exist yet.

one potential fix would be to simply ignore if repos fail as long as we can get the appropriate debuginfo packages or to stop shipping repo files for stable setups in the rawhide release packages (but that is hardly controllable with 3rd party -release packages that include repo files.)
Comment 7 Bug Zapper 2010-07-30 08:30:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bruce Cowan 2010-09-21 20:03:07 EDT
Bug #630434 suggests the fix to this
Comment 9 Radek Vokal 2010-10-07 03:18:15 EDT
Got the same problem, abrt-1.1.13-2.fc14.x86_64 won't find any debuginfos. It won't even start yum. Denys, if you got trouble to reproduce, my box is yours ..
Comment 10 Rudolf Kastl 2010-10-07 06:18:53 EDT
radek this is probably not the same problem. since the initial report here is a rawhide specific one. see comment #6. you might see the same or a similar symptom though.
Comment 11 Rudolf Kastl 2010-10-25 10:40:19 EDT
setting back to rawhide... it only fails on rawhide.
Comment 12 Rudolf Kastl 2010-12-15 04:36:19 EST
as told on irc: ping :D
Comment 13 Fedora Update System 2011-03-27 13:36:19 EDT
abrt-2.0.0-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-1.fc15
Comment 14 Fedora Update System 2011-03-29 16:01:41 EDT
abrt-2.0.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-2.fc15
Comment 15 Fedora Update System 2011-03-29 22:32:20 EDT
Package abrt-2.0.0-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.0-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/abrt-2.0.0-2.fc15
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2011-03-30 12:48:39 EDT
abrt-2.0.0-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-3.fc15
Comment 17 Fedora Update System 2011-04-04 10:08:22 EDT
abrt-2.0.0-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-4.fc15
Comment 18 Fedora Update System 2011-04-15 11:09:21 EDT
abrt-2.0.0-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-5.fc15
Comment 19 Fedora Update System 2011-04-20 09:29:59 EDT
abrt-2.0.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.1-1.fc15
Comment 20 Fedora Update System 2011-04-21 12:44:37 EDT
abrt-2.0.1-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.1-2.fc15
Comment 21 Fedora Update System 2011-04-26 12:12:02 EDT
abrt-2.0.1-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.