Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 613449 - cron manpage contains incorrect information
cron manpage contains incorrect information
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cronie (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-11 13:47 EDT by Denys Vlasenko
Modified: 2010-10-22 05:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-22 05:00:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denys Vlasenko 2010-07-11 13:47:38 EDT
man crond shows the following (my comment are with ***):

CRON(8)                                                                CRON(8)

NAME
       cron - daemon to execute scheduled commands (cronie V1.2)

SYNOPSIS
       cron [-n | -p | -m<mailcommand>]
       cron -x [ext,sch,proc,pars,load,misc,test,bit]

*** cron? there is no "cron" command, it's *crond*. (Thre is even "man cron" manpage alias, but there is no actual "cron" *command*).

...
       There are two ways, how the changes  are  checked  in  crontables.

*** The comma is perhaps not needed. I'd also replace "crontables" with "crontabs".

       The
       first  is  checking  the modtime of file and the other is using inotify
       support.

*** I am no expert, but it looks like slightly broken English, should be "The first METHOD is ... and the other ONE is ..."

       You can find out which of them are you using,  if  you  check
       /var/log/cron where is (or isn’t) inotify mentioned after start of dae-
       mon.

*** More English breakage. I propose "You can find out which of them are in use by checking crond log (see whether it mentions inotify or not)"

       The inotify support is watching for changes in all crontables  and
       touch the disk only in case that something was changed.

       In  other case cron checks each minute to see if its crontables modtime
       have changes and reload those which have changes.

*** More. crontables -> crontabs' , reload -> reloads

       There is no  need  to
       restart  cron  after  some of the crontable is modified.

*** crontable -> crontabs

       This option is
       used also when inotify couldn’t be initialized.

       Cron is  checking  those  files  or  directories:

*** Cron is  checking -> Crond checks

       /etc/crontab  system
       crontab   is  usually  for  running  daily,  weekly,  monthly  jobs.
       /etc/cron.d/ where are system cronjobs stored for  different  users.

*** Badly phrased.

       /var/spool/cron that’s mean spool directory for user crontables.

*** "mean spool directory"? It's basically means "bad spool directory" :D

       Note  that  the  crontab(1)  command  updates  the modtime of the spool
       directory whenever it changes a crontab.

...


       -n     This  option changes default behavior causing it to run crond in
              the foreground.  This can be useful  when  starting  it  out  of
              init.

*** What first word "it" refers to in the text above? I'd replace the whole first sentence with: "Run in foreground."

       -p     Cron permit any crontab, which user set.

*** I don't understand what manpage is trying to say here.

       -x     With this option is possible to set debug flags.

*** How about just: " -x FLAG    Set debug flag". Can I specify more than one flag?
Comment 1 Marcela Mašláňová 2010-07-12 01:47:11 EDT
This elaboration would be better from native speaker. But ok, I'll try to find someone who can look at it.
Comment 2 Bug Zapper 2010-07-30 08:30:57 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Marcela Mašláňová 2010-10-22 05:00:11 EDT
New version 1.4.6 contains rewritten man pages. Now it's in rawhide, but it will be in updates for F-13,14 soon.

Note You need to log in before you can comment on or make changes to this bug.