Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 613454 - Upgrade from FC11 to FC13 breaks KDE
Upgrade from FC11 to FC13 breaks KDE
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-11 14:33 EDT by Nigel Horne
Modified: 2010-07-12 04:06 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 04:02:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2010-07-11 14:33:34 EDT
Description of problem:
Since upgrading from FC11 to FC13 I haven't been able to login to KDE.  Instead the cryptic and unhelpful message "kstartupconfig4 does not exist or fails. The error code Okay" is displayed.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Upgrade from FC11 to FC13
2. Try to login
3.
  
Actual results:
kstartupconfig4 does not exist or fails. The error code Okay

Expected results:
Desktop should appear

Additional info:
Comment 1 Kevin Kofler 2010-07-11 18:28:15 EDT
How did you upgrade? Using the DVD? Then you need to run "yum update" after the DVD upgrade.
Comment 2 Nigel Horne 2010-07-12 03:18:37 EDT
Yes - I used the DVD from the Fedora site.

How do I login to run "yum update"?
Comment 3 Kevin Kofler 2010-07-12 04:02:15 EDT
Try text mode: add a space and the number 3 to the kernel parameters when booting in GRUB.

This is a known problem with DVD upgrades: they don't include updates and as such they're prone to upgrade path issues like this. Other methods such as preupgrade are more reliable.
Comment 4 Kevin Kofler 2010-07-12 04:06:55 EDT
To clarify the "prone to" part: it's IMPOSSIBLE to upgrade a Fedora 11 or 12 with updates to Fedora 13 using the DVD without breaking KDE until the first "yum update". This will ALWAYS happen, due to the way the DVD upgrade works (and it was the same in most past releases; when it worked, it was only by accident because no core system library was upgraded to a binary-incompatible version).

Note You need to log in before you can comment on or make changes to this bug.