Bug 613493 - x200 hibernate kernel panic
Summary: x200 hibernate kernel panic
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
high
Target Milestone: rc
: ---
Assignee: Prarit Bhargava
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On: 629274
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-12 01:57 UTC by Qian Cai
Modified: 2011-04-20 13:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-20 13:22:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
panic screenshot (409.96 KB, image/jpeg)
2010-07-12 01:57 UTC, Qian Cai
no flags Details

Description Qian Cai 2010-07-12 01:57:42 UTC
Created attachment 431045 [details]
panic screenshot

Description of problem:
kernel panic during suspend to disk.

Version-Release number of selected component (if applicable):
kernel-debug-2.6.32-44.el6
RHEL6.0-20100707.4

How reproducible:
Once.

Comment 3 Peter Martuccelli 2010-07-29 17:24:13 UTC
Moving out to RHEL 6.1, if QE can reproduce the problem for us then we can reopen the issue.

Comment 8 Prarit Bhargava 2010-08-10 18:29:50 UTC
I've looked at the code forwards, backward, and upside down, looking for a situation where the cpu_hotplug.lock is acquired after a cpu's cpu_policy_rwsem.

I can't find one :/.  This could be a symptom of the strange race described in the description of cpu_hotplug_begin() ... but it doesn't feel like that is the cause.

This has happened one time, and doesn't appear to be easily reproducible so I'm moving this to 6.1 for now.

P.

Comment 10 Prarit Bhargava 2011-03-09 15:09:55 UTC
Has this happened again?  I cannot find any bugs on suspend/resume on the x200 in bugzilla ...

P.

Comment 12 Prarit Bhargava 2011-04-20 13:23:08 UTC
I had Cai's x200 here for a few days and used it diagnose another failure with suspend/resume.

I did not see the type of issue being reported in this BZ.

P.


Note You need to log in before you can comment on or make changes to this bug.