Bug 6135 - KDE 1.1.2 RPMs not relocatable
Summary: KDE 1.1.2 RPMs not relocatable
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-20 13:36 UTC by guillaume.assire
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-01 14:26:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description guillaume.assire 1999-10-20 13:36:29 UTC
Why do all these RPM packages claim they are relocatable ?
Actually, all of them but one (kdelibs) say "Relocatable:
/usr". As I stated on the KDE-redHat mailing list, I find
that the configuration files are always installed in /etc,
and the doc files in /usr/doc/kde/HTML.

May I suggest changing this location, precisely because it
doesn't allow relocatable packages ? Moving all the HTML
stuff to /usr/share/doc/HTML would allow relocatable RPMs,
unless they have config files (which is rarely the case).
For example, if I want to create RPM packages for both Red
Hat users (FHS compliant) and others, I'd like to be able to
replace /usr with /opt/kde for example. These doc files
would then reside in /opt/kde/share/doc/HTML, which is their
proper location in the KDE tree. While with the new Red Hat
package location, they would go to /opt/kde/doc/kde/HTML if
one try to "relocate" them...

How much would it break the FHS compliance ?

Guillaume.

Comment 1 Preston Brown 1999-12-01 14:26:59 UTC
It would completely violate FHS compliance.  Whether that actually matters or
not is a subject of current debate.

We'll be evaluating this as an option next time we make packages, but don't hold
your breath.  We often get accused of not supporting standards groups enough,
and then we do, we take even more heat.  It's a lose-lose situation it seems.


Note You need to log in before you can comment on or make changes to this bug.