Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 613598 - Fn-F7 (switchvideomode) causes panic on T410
Fn-F7 (switchvideomode) causes panic on T410
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 07:36 EDT by Robert de Rooy
Modified: 2018-04-11 02:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-26 03:31:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (58.92 KB, text/plain)
2010-07-12 07:37 EDT, Robert de Rooy
no flags Details
Xorg log (171.65 KB, text/plain)
2010-07-12 07:42 EDT, Robert de Rooy
no flags Details
Same problem on F13, Dell D630 (32.97 KB, text/plain)
2010-09-30 02:32 EDT, Norman Gaywood
no flags Details

  None (edit)
Description Robert de Rooy 2010-07-12 07:36:06 EDT
Description of problem:
This worked fine on my previous ThinkPad with Intel graphics, but on my new T410 (Intel HD Graphics) pressing Fn-F7 with an external display attached causes the LVDS to switch off and the system no longer responds to the keyboard.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.11.0-5.fc13.x86_64
kernel-2.6.34.1-9.fc13.x86_64

Rawhide also tested and gave the same result

How reproducible:
Every time

Steps to Reproduce:
1. Login
2. Attach external display
3. Press Fn-F7
  
Actual results:
LVDS is black as is the external display, no response to keyboard (not even the capslock light turns on any more)

Expected results:
Cycle through video modes, as it did on my old ThinkPad

Additional info:

syslog shows;
[drm:intel_lvds_mode_fixup] *ERROR* Can't enable LVDS and another encoder on the same pipe
[drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88012f973800

followed a little bit later with a panic

BUG: soft lockup - CPU#3 stuck for 61s! [Xorg:1961]
Modules linked in: aes_x86_64 aes_generic fuse tun rfcomm sco bridge stp llc bnep l2cap ppdev parport_pc parport cpufreq_ondemand acpi_cpufreq freq_table iptable_nat nf_nat ipt_LOG xt_limit uinput snd_hda_codec_intelhdmi snd_hda_intel arc4 ecb snd_hda_codec snd_hwdep snd_seq iwlagn iTCO_wdt snd_seq_device btusb iwlcore iTCO_vendor_support mac80211 snd_pcm sdhci_pci bluetooth cfg80211 e1000e sdhci uvcvideo videodev i2c_i801 v4l1_compat snd_timer snd_page_alloc thinkpad_acpi v4l2_compat_ioctl32 rfkill mmc_core wmi joydev snd soundcore microcode firewire_ohci firewire_core crc_itu_t i915 drm_kms_helper drm i2c_algo_bit i2c_core video output [last unloaded: scsi_wait_scan]
CPU 3 
Modules linked in: aes_x86_64 aes_generic fuse tun rfcomm sco bridge stp llc bnep l2cap ppdev parport_pc parport cpufreq_ondemand acpi_cpufreq freq_table iptable_nat nf_nat ipt_LOG xt_limit uinput snd_hda_codec_intelhdmi snd_hda_intel arc4 ecb snd_hda_codec snd_hwdep snd_seq iwlagn iTCO_wdt snd_seq_device btusb iwlcore iTCO_vendor_support mac80211 snd_pcm sdhci_pci bluetooth cfg80211 e1000e sdhci uvcvideo videodev i2c_i801 v4l1_compat snd_timer snd_page_alloc thinkpad_acpi v4l2_compat_ioctl32 rfkill mmc_core wmi joydev snd soundcore microcode firewire_ohci firewire_core crc_itu_t i915 drm_kms_helper drm i2c_algo_bit i2c_core video output [last unloaded: scsi_wait_scan]

Pid: 1961, comm: Xorg Not tainted 2.6.34.1-9.fc13.x86_64 #1 2522AT6/2522AT6
RIP: 0010:[<ffffffffa008dc6c>]  [<ffffffffa008dc6c>] intel_lvds_set_power+0x90/0x12e [i915]
RSP: 0018:ffff88013217bcc8  EFLAGS: 00000286
RAX: ffff88012f328000 RBX: ffff88013217bcc8 RCX: 00000000000c7200
RDX: 000000000000000a RSI: 000000008030833e RDI: ffff88012f973000
RBP: ffffffff8100a60e R08: ffffc90011947204 R09: ffffc90011961180
R10: 0000000000000000 R11: 0000000000003246 R12: 00000000811267e7
R13: ffff88013217be50 R14: 000000000000003a R15: ffff88013217bc68
FS:  00007fe1e11fc840(0000) GS:ffff880002180000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 000000337da2b770 CR3: 0000000132186000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process Xorg (pid: 1961, threadinfo ffff88013217a000, task ffff880130af4650)
Stack:
 ffff88013217bcd8 ffffffffa008dd26 ffff88013217bd08 ffffffffa00672b4
<0> ffff8801337207e0 ffff88013217bda8 ffff88012f976000 ffff88012f976240
<0> ffff88013217bd58 ffffffffa0036726 0000000003725158 ffff88012f973408
Call Trace:
 [<ffffffffa008dd26>] ? intel_lvds_dpms+0x1c/0x1e [i915]
 [<ffffffffa00672b4>] ? drm_helper_connector_dpms+0x11d/0x209 [drm_kms_helper]
 [<ffffffffa0036726>] ? drm_mode_connector_property_set_ioctl+0x108/0x175 [drm]
 [<ffffffffa002c5df>] ? drm_ioctl+0x259/0x36a [drm]
 [<ffffffff810cb8d6>] ? generic_file_aio_write+0x8b/0xa7
 [<ffffffffa003661e>] ? drm_mode_connector_property_set_ioctl+0x0/0x175 [drm]
 [<ffffffff8110d95b>] ? do_sync_write+0xcb/0x108
 [<ffffffff8111a703>] ? vfs_ioctl+0x32/0xa6
 [<ffffffff8111ac76>] ? do_vfs_ioctl+0x483/0x4c9
 [<ffffffff8110d737>] ? fsnotify_modify+0x6c/0x74
 [<ffffffff8111ad12>] ? sys_ioctl+0x56/0x79
 [<ffffffff81009c72>] ? system_call_fastpath+0x16/0x1b
Code: 31 81 ce 00 00 00 80 41 89 31 48 03 50 18 8b 12 45 89 c0 4c 03 40 18 41 8b 10 83 ca 01 41 89 10 89 c9 48 89 ca 48 03 50 18 8b 12 <85> d2 79 f3 48 8b 97 88 03 00 00 8b b0 c8 04 00 00 48 8b 42 08 
Call Trace:
 [<ffffffffa008dd26>] ? intel_lvds_dpms+0x1c/0x1e [i915]
 [<ffffffffa00672b4>] ? drm_helper_connector_dpms+0x11d/0x209 [drm_kms_helper]
 [<ffffffffa0036726>] ? drm_mode_connector_property_set_ioctl+0x108/0x175 [drm]
 [<ffffffffa002c5df>] ? drm_ioctl+0x259/0x36a [drm]
 [<ffffffff810cb8d6>] ? generic_file_aio_write+0x8b/0xa7
 [<ffffffffa003661e>] ? drm_mode_connector_property_set_ioctl+0x0/0x175 [drm]
 [<ffffffff8110d95b>] ? do_sync_write+0xcb/0x108
 [<ffffffff8111a703>] ? vfs_ioctl+0x32/0xa6
 [<ffffffff8111ac76>] ? do_vfs_ioctl+0x483/0x4c9
 [<ffffffff8110d737>] ? fsnotify_modify+0x6c/0x74
 [<ffffffff8111ad12>] ? sys_ioctl+0x56/0x79
 [<ffffffff81009c72>] ? system_call_fastpath+0x16/0x1b
Comment 1 Robert de Rooy 2010-07-12 07:37:18 EDT
Created attachment 431146 [details]
dmesg
Comment 2 Robert de Rooy 2010-07-12 07:42:31 EDT
Created attachment 431147 [details]
Xorg log
Comment 3 Robert de Rooy 2010-08-22 12:15:52 EDT
I tried it with F14 alpha, and the same thing happens

kernel-2.6.35.2-9.fc14.x86_64
xorg-x11-server-Xorg-1.8.99.906-2.fc14.x86_64
xorg-x11-drv-intel-2.12.0-4.fc14.x86_64
libdrm-2.4.21-3.fc14.x86_64
Comment 4 Robert de Rooy 2010-08-31 07:54:00 EDT
I tried kernel-2.6.36-0.12.rc3.git0.fc15.x86_64 on top of F14 Alpha, and the behaviour has changed.

first of all, a regression, hotplugging the VGA display no longer caused the display to be automatically enabled. I had to run xrandr and then it switched to extended desktop.

pressing Fn-F7 the 1st time gave me mirror mode with both displays in 1024x768.

pressing Fn-F7 the 2nd time gave vertical lines on the LVDS and diagonal lines on the top part of the display with lots of flicker. The VGA display was black.

pressing Fn-F7 the 3rd time gave vertical lines on the VGA and horizontal lines on the top part of the display with lots of flicker. The LVDS display was black.

pressing Fn-F7 the 4th time gave extended desktop without corruption.
Comment 5 Norman Gaywood 2010-09-30 02:32:32 EDT
Created attachment 450667 [details]
Same problem on F13, Dell D630

I'm seeing the same problem with F13 on a Dell D630 laptop. I use the menus to select mirror mode and dmesg explodes with the attacted messages. Screens are blank and the laptop keyboard is locked up.

network is still working, which is how I got these messages.

dmesg starts with:
[drm:intel_lvds_mode_fixup] *ERROR* Can't enable LVDS and another encoder on the same pipe
[drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc f6921800

Waits a while then the rest starting with:

BUG: soft lockup - CPU#1 stuck for 61s! [Xorg:1696]
Comment 6 Norman Gaywood 2010-09-30 02:36:35 EDT
Same as bug #628906 ?
Comment 7 Robert de Rooy 2010-10-26 03:07:55 EDT
With F14 it now works, both for VGA and DVI. And since I upgraded, I will not be doing any more testing with F13.
Comment 8 Matěj Cepl 2010-10-26 03:31:22 EDT
OK, let's close this one, and if anybody here on CC list feels this is still an issue for her, please, open a new bug (and mention it here, so I can quickly jump on it).

Thank you

Note You need to log in before you can comment on or make changes to this bug.