Bug 613656 - Add 'ignore' button in notifications
Summary: Add 'ignore' button in notifications
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Denys Vlasenko
QA Contact: Michal Nowak
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-12 14:13 UTC by David Kovalsky
Modified: 2014-03-31 23:45 UTC (History)
9 users (show)

Fixed In Version: abrt-1.1.10-1.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 19:33:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (2.07 KB, patch)
2010-07-14 12:35 UTC, Denys Vlasenko
no flags Details | Diff

Description David Kovalsky 2010-07-12 14:13:30 UTC
I'm getting tired of of abrt notifications popping up everytime my Firefox crashes (known issue, basically every time I close FF). 

If abrt can't tell it's the same crash over and over again which I already reported, I'd like to see a new feature - 'ignore' button every time the notification of application crashes pops up. This way I wouldn't have to go through the 

open abrt -> delete crash -> close route every time.

abrt-1.1.8-2.el6.x86_64

Comment 3 Denys Vlasenko 2010-07-14 12:35:37 UTC
Created attachment 431749 [details]
Proposed patch

The patch makes abrt-applet to not show the crash dialog if the following conditions are met:

* the component is the same as in last crash
* the crash id is the same (abrtd's dup detection makes same crash to have same crash id. Thus, the report about DIFFERENT crash in the same executable will not be suppressed)
* less than 30 minutes passed since last crash (rationale: we do want to let used know that the crash still happens)

Note that icon is not suppressed, it will appear in the tray every time there is a new crash, even if it is the same. The icon is much less annoying.

Comment 4 Denys Vlasenko 2010-07-14 15:01:58 UTC
Applied to git.

Comment 5 Denys Vlasenko 2010-07-15 15:02:26 UTC
Fixed in abrt-1.1.10-1.el6

Not by means of adding an [Ignore] button, but by suppressing the crash notification dialog for a period of time. Let's see how well that will work in practice.

Comment 8 releng-rhel@redhat.com 2010-11-10 19:33:46 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.