Bug 613695 - ImportError: cannot import name GObject
ImportError: cannot import name GObject
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
anaconda_trace_hash:8c24a10af257c201b...
:
Depends On:
Blocks: F14Alpha/F14AlphaBlocker
  Show dependency treegraph
 
Reported: 2010-07-12 11:25 EDT by James Laska
Modified: 2013-09-02 02:49 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-14.11-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-23 15:24:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (85.38 KB, text/plain)
2010-07-12 11:25 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2010-07-12 11:25:03 EDT
The following was filed automatically by anaconda:
anaconda 14.10 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/gtk-2.0/gi/__init__.py", line 27, in <module>
    from gi.repository import GObject
  File "/tmp/updates/pyanaconda/iw/filter_gui.py", line 106, in isRAID
    if flags.dmraid:
  File "/tmp/updates/pyanaconda/iw/filter_gui.py", line 161, in isMember
    return info and (isRAID(info) or isCCISS(info))
  File "/tmp/updates/pyanaconda/iw/filter_gui.py", line 521, in _page_switched
    line[VISIBLE_COL] = self.pages[page_num].cb.isMember(line[OBJECT_COL])
ImportError: cannot import name GObject
Comment 1 James Laska 2010-07-12 11:25:08 EDT
Created attachment 431200 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2010-07-12 11:28:24 EDT
If I update everything on my local workstation, I see various other errors:

In [1]: import gtk
** Message: pygobject_register_sinkfunc is deprecated (GtkWindow)
** Message: pygobject_register_sinkfunc is deprecated (GtkInvisible)
** Message: pygobject_register_sinkfunc is deprecated (GtkObject)
gtk/__init__.py:40: RuntimeWarning: tp_compare didn't return -1 or -2 for exception
  from gtk import _gtk
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)

/usr/lib64/python2.6/site-packages/gtk-2.0/gi/__init__.py in <module>()
     21 from __future__ import absolute_import
     22 
---> 23 from ._gi import _API
     24 
     25 # Force loading the GObject typelib so we have available the wrappers for


ImportError: gi/_gi.so: undefined symbol: g_type_info_get_array_type


clumens@exeter:/usr/lib64/python2.6/site-packages/gtk-2.0$ rpm -qa pygtk\* pygobject\*
pygtk2-2.17.0-3.fc13.x86_64
pygobject2-2.21.4-4.fc14.x86_64
pygtkglext-1.1.0-8.fc13.x86_64
pygtk2-codegen-2.17.0-3.fc13.x86_64
pygobject2-devel-2.21.4-4.fc14.x86_64
pygtksourceview-2.10.1-1.fc14.x86_64
pygtk2-doc-2.17.0-3.fc13.noarch
pygobject2-codegen-2.21.4-4.fc14.x86_64
pygtk2-devel-2.17.0-3.fc13.x86_64
pygtk2-libglade-2.17.0-3.fc13.x86_64
pygobject2-doc-2.21.4-4.fc14.x86_64
Comment 3 Colin Walters 2010-07-12 11:40:53 EDT
Looks like your version of gobject-introspection is too old; I'll update the Requires.
Comment 4 Colin Walters 2010-07-12 11:57:09 EDT
(In reply to comment #0)
> The following was filed automatically by anaconda:
> anaconda 14.10 exception report
> Traceback (most recent call first):
>   File "/usr/lib64/python2.6/site-packages/gtk-2.0/gi/__init__.py", line 27, in
> <module>
>     from gi.repository import GObject
>   File "/tmp/updates/pyanaconda/iw/filter_gui.py", line 106, in isRAID
>     if flags.dmraid:
>   File "/tmp/updates/pyanaconda/iw/filter_gui.py", line 161, in isMember
>     return info and (isRAID(info) or isCCISS(info))
>   File "/tmp/updates/pyanaconda/iw/filter_gui.py", line 521, in _page_switched
>     line[VISIBLE_COL] = self.pages[page_num].cb.isMember(line[OBJECT_COL])
> ImportError: cannot import name GObject    

This looks like $libdir/girepository-1.0/GObject.typelib is missing.

Is anaconda's operating system image constructor based on a whitelist?  If so this file needs to be added.
Comment 5 Martin Gracik 2010-07-14 09:38:23 EDT
Yes, image constructor is based on a whitelist, but what package provides those libs? 'Cause I can't find them, and maybe we also need to add some packages too.
Comment 6 Martin Gracik 2010-07-14 09:51:46 EDT
Oh yes, it's /usr/$libdir, and gobject-introspection package.
Comment 7 Martin Gracik 2010-07-14 10:10:47 EDT
Ok, so if this is really only missing files in the install.img problem, I already have a patch for it.
Comment 8 Adam Williamson 2010-07-16 12:23:53 EDT
Discussed at 2010/07/16 blocker meeting. We're not sure if this actually breaks any Alpha criteria. We noted that in the acceptance test page the description is listed as:

"ImportError: cannot import name GObject when attempting to active advanced storage devices "

Does this bug only appear when selecting the 'advanced storage devices' option? If so, I think it doesn't break the Alpha criteria, which are only:

"The installer must be able to complete an installation using IDE, SATA and SCSI storage devices, with the default file system and LVM"

I don't believe any of those requires the use of the advanced storage devices option, do they?

Please advise whether this bug is actually breaking any of the Alpha criteria. Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Chris Lumens 2010-07-16 12:54:29 EDT
This should be fixed in the current build.
Comment 10 John Poelstra 2010-07-21 00:00:44 EDT
Dear Bug Reporter,

This blocker bug has been marked as fixed.  If possible could you verify that this problem is in fact fixed in the latest build?  Your help in completing this task and adding a comment to this bug prior to the next Fedora 14 Alpha Blocker meeting on Friday, July 23, 2010, would be most appreciated.

Thank you,
John
Comment 11 James Laska 2010-07-23 12:29:32 EDT
Discussed at F14 Alpha blocker review meeting#2.  No change in blocker status, this bug is awaiting re-test on the next rawhide acceptance test run.
Comment 12 James Laska 2010-07-23 15:24:28 EDT
Confirmed fixed in rawhide-20100722 (anaconda-14.12-1).  Install images can be found at http://serverbeach1.fedoraproject.org/pub/alt/stage/rawhide-20100722/

Note You need to log in before you can comment on or make changes to this bug.