This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 613701 - Repetitive changing of a brand results in wrong document rendering
Repetitive changing of a brand results in wrong document rendering
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All All
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 11:43 EDT by Jaromir Hradilek
Modified: 2010-11-23 23:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-27 00:47:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaromir Hradilek 2010-07-12 11:43:20 EDT
Description of problem:
Changing a brand from "common" to "RedHat" and back again results in wrong rendering of a book.

Version-Release number of selected component (if applicable):
publican 2.1

How reproducible:
Always.

Steps to Reproduce:
1. Create a new book typing "publican create --name Broken".
2. In publican.cfg, change the brand from "common" to "RedHat", and build the book typing "publican build --langs=en-US --formats=html-desktop".
3. In publican.cfg, change the brand back to "common", and build the book with the command above once again.
4. Open tmp/en-US/html-desktop/index.html in a web browser.
  
Actual results:
The document appears to combine the brands together: although the title page uses the correct heading and images, chapter and section headings are red instead of blue, example frames are grey instead of orange, etc.

Expected results:
The document should have correct appearance as defined by the current brand.

Additional info:
None at the moment.
Comment 1 Ruediger Landmann 2010-07-12 19:35:42 EDT
This occurs because the Red Hat brand contains an overrides.css file that overrides certain parts of the default.css of the common brand. Since you built the book first with the Red Hat brand, the overrides.css file for that brand was still in the tmp/en-US/html-desktop directory when you built it with the common brand which doesn't contain an overrides.css file.

To work around this, run "publican clean" between builds, or simply delete tmp/en-US/html-desktop/Common_Content/css/overrides.css

Note that this scenario only arises when switching to a brand that lacks an overrides.css from some other brand that includes an overrides.css.
Comment 2 Jeff Fearn 2010-07-27 00:47:16 EDT
I'm going to close this NOTABUG since all it requires is running 'publican clean'; we can't automatically run clean every build as it breaks a lot of use cases.

Note You need to log in before you can comment on or make changes to this bug.