Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 613703 - cups-libs subpackage must also include a copy of license text
cups-libs subpackage must also include a copy of license text
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cups (Show other bugs)
6.1
All Linux
low Severity low
: rc
: ---
Assigned To: Tim Waugh
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 11:48 EDT by Jiri Popelka
Modified: 2010-11-18 10:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-18 10:01:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Popelka 2010-07-12 11:48:03 EDT
LICENSE file is only included in base package, i.e. cups.
According to Fedora Licensing Guidelines
the -libs subpackage must also include a copy of license text.


From
http://lists.fedoraproject.org/pipermail/devel/2010-July/138487.html
Q. My package generates a foo and foo-libs package. foo has the license
files, and foo depends on foo-libs, but foo-libs doesn't have any
license files in it. What should I do?
A. You have two options here. You can either move the license texts from
foo to foo-libs or duplicate the license texts in both packages. Moving
the license texts is an acceptable option in this case because it
ensures that if foo-libs is installed, the license texts are present,
and if foo is installed, it will pull in foo-libs, thus, the license
texts are present.



Additional info:
http://lists.fedoraproject.org/pipermail/devel/2010-July/138487.html
http://lists.fedoraproject.org/pipermail/devel/2010-July/138546.html
http://lists.fedoraproject.org/pipermail/scm-commits/2010-July/460620.html

Note You need to log in before you can comment on or make changes to this bug.