Bug 61372 - It's difficult to reinstall a corrupted package.
It's difficult to reinstall a corrupted package.
Status: CLOSED DUPLICATE of bug 61373
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-18 13:45 EST by Max TenEyck Woodbury
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-18 13:45:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max TenEyck Woodbury 2002-03-18 13:45:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en] (WinNT; I)

Description of problem:
For any of a number of reasons, a package instilation may need to be redone. In particular, some files in a package may have been deleted or corrupted. (The 
notorious 'rm -rR /' is a good example of this.) Assuming the RPM database has survived and you have
access to a package distribution, it
should be fairly easy to verify which files are missing or corrupt and reinstall them. The current implementation makes locating the missing/corrupted file possible, but 
it 
is NOT easy to do the update. Either add a 'fixit' option to 'verify' mode, or add a seperate 'fixit' mode. Interactive confirmation and batch mode would be useful 
options. 
On the other hand, if this already exists, I couldn't find anything on the subject in the documentation.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rm -fR /
2.^C (quickly!)
3.rpm -Va (or whatever...)
  Now what do you do?
	

Actual Results:  You're SOL and probably out on the street looking for a new job.

Expected Results:  4.mount /mnt/cdrom
5./mnt/cdrom/.../rpm -Va --fixit -interactive

Additional info:

This would be useful wien a machine has had a security compromise.
Comment 1 Jeff Johnson 2002-03-18 15:41:33 EST

*** This bug has been marked as a duplicate of 61373 ***
Comment 2 Max TenEyck Woodbury 2002-03-19 00:17:16 EST
Sorry, browser trouble...
Comment 3 Jeff Johnson 2002-03-19 10:14:33 EST
Happens to me all the time, bugzilla has
some (ahem) confusing deficiencies :-)

Note You need to log in before you can comment on or make changes to this bug.