Bug 613739 - KVM: PIT: stop vpit before freeing irq_routing (upstream backport)
KVM: PIT: stop vpit before freeing irq_routing (upstream backport)
Status: CLOSED DUPLICATE of bug 612648
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 14:09 EDT by Marcelo Tosatti
Modified: 2010-07-13 15:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 15:34:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcelo Tosatti 2010-07-12 14:09:38 EDT
Fix:
    general protection fault: 0000 [#1] PREEMPT SMP DEBUG_PAGEALLOC
    ......
    Call Trace:
     [<ffffffffa0159bd1>] ? kvm_set_irq+0xdd/0x24b [kvm]
     [<ffffffff8106ea8b>] ? trace_hardirqs_off_caller+0x1f/0x10e
     [<ffffffff813ad17f>] ? sub_preempt_count+0xe/0xb6
     [<ffffffff8106d273>] ? put_lock_stats+0xe/0x27
    ...
    RIP  [<ffffffffa0159c72>] kvm_set_irq+0x17e/0x24b [kvm]
    
    This bug is triggered when guest is shutdown, is because we freed
    irq_routing before pit thread stopped

    Signed-off-by: Xiao Guangrong <xiaoguangrong@cn.fujitsu.com>
    Signed-off-by: Marcelo Tosatti <mtosatti@redhat.com>
Comment 2 Marcelo Tosatti 2010-07-13 15:34:15 EDT

*** This bug has been marked as a duplicate of bug 612648 ***

Note You need to log in before you can comment on or make changes to this bug.