Bug 613763 - Fedora 13 freezes (stops responsing to mouse and keyboard input) on Dell Vostro 3700
Fedora 13 freezes (stops responsing to mouse and keyboard input) on Dell Vost...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 15:05 EDT by Chris January
Modified: 2011-06-29 09:38 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-29 09:38:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log (48.84 KB, text/plain)
2010-07-13 08:57 EDT, Chris January
no flags Details
messages log file (105.37 KB, text/plain)
2010-07-13 08:58 EDT, Chris January
no flags Details
boot.log log file (2.02 KB, text/x-log)
2010-07-13 08:58 EDT, Chris January
no flags Details
Xorg.0.log log file (136.24 KB, text/x-log)
2010-07-13 08:59 EDT, Chris January
no flags Details
dmesg log (from working Ubuntu installation) (54.62 KB, application/octet-stream)
2010-07-13 09:01 EDT, Chris January
no flags Details
diff between dmesg logs from working and non-working boots (101.27 KB, text/plain)
2010-07-13 09:27 EDT, Chris January
no flags Details
Graphical corruption on login screen booting with 2.6.3.4.1-11.fc13 kernel (1.09 MB, image/jpeg)
2010-07-21 04:03 EDT, Chris January
no flags Details

  None (edit)
Description Chris January 2010-07-12 15:05:51 EDT
Description of problem:

I recently tried installing Fedora 13 on a Dell Vostro 3700 laptop (Smolt
profile:
http://www.smolts.org/client/show/pub_970e240b-29c8-499d-a137-d645db440137).
The installer froze several times (i.e. the machine stopped responding to
mouse or keyboard input) so that it took several attempts before a
successfull install. After Fedora was installed it would freeze within
about 5 minutes of booting. I tried changing the hard disk controller from
AHCI to ATA mode in the BIOS (as this fixed a freeze during Windows 7
setup) but that did not fix it.
I am currently running Ubuntu 10.04 and that works fine, with no freezes,
but I would really like to be able to run Fedora 13 instead. Ubuntu has a
2.6.32 kernel, whereas Fedora has a 2.6.33 kernel, if that makes a
difference.
I can test new kernels, but only from a USB stick as I don't want to
replace the Ubuntu install until I'm sure Fedora will work.

Version-Release number of selected component (if applicable):

kernel-2.6.33.3-85.fc13.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. Install Fedora 13 on a Vostro 3700
  
Actual results:

Installer locks up (stops responding to keyboard and mouse input). If you manage to install then within about 5 minutes of booting the desktop locks up.

Expected results:

Fedora never locks up and is perfect in every way ;)

Additional info:

Smolt profile: http://www.smolts.org/client/show/pub_970e240b-29c8-499d-a137-d645db440137
Comment 1 vincentvdk 2010-07-13 03:31:18 EDT
Hi, 

I also have a Dell Vostro 3700, and I can confirm the above symptoms.

If i connect a USB mouse during installation, the system hangs completely (HD led keeps burning) and I need to power cycle.

When i install not using en external mouse, the installation finishes without issues. 
If I connect a mouse after the installation, the system hangs again.

I also have issues doing the installation from the Fedora installation DVD. There it hangs at "mounting /tmps ....". The same happens with RHEL 6.0 b2.
 
I'm also running Ubuntu 10.04 which is strange after years of Fedora/Red Hat.

Regards,
Vincent.
Comment 2 Chris January 2010-07-13 05:22:30 EDT
I'm glad someone else can confirm this issue. Just for the record, I have reproduced this issue without an external mouse.
Comment 3 Chris January 2010-07-13 08:56:54 EDT
Not sure if any of these errors are relevant:

ACPI: I/O resource 0000:00:1f.3 [0xf000-0xf01f] conflicts with ACPI region SMBI [0xf000-0xf00f]

ACPI: RSDP 00000000000f0410 00024 (v03 DELL  )
ACPI: XSDT 00000000bf5db088 00064 (v01 DELL    WN09    01072009 AMI  00010013)
ACPI: FACP 00000000bf5e4d30 000F4 (v04 DELL    WN09    01072009 AMI  00010013)
ACPI Warning: 32/64 FACS address mismatch in FADT - two FACS tables! (20091214/tbfadt-369)
ACPI Warning: 32/64X FACS address mismatch in FADT - BF62DF40/00000000BF62DF80, using 32 (20091214/tbfadt-486)
ACPI: DSDT 00000000bf5db180 09BAB (v02 DELL    WN09    00000070 INTL 20051117)
ACPI: FACS 00000000bf62df40 00040
ACPI: APIC 00000000bf5e4e28 00072 (v01 DELL   WN09     01072009 AMI  00010013)
ACPI: SSDT 00000000bf5e4ea0 0014E (v01 AMICPU     PROC 00000001 MSFT 03000001)
ACPI: MCFG 00000000bf5e4ff0 0003C (v01   DELL     WN09 01072009 MSFT 00000097)
ACPI: SLIC 00000000bf5e5030 00176 (v01 DELL    WN09    01072009 AMI  00010013)
ACPI: HPET 00000000bf5e51a8 00038 (v01   DELL     WN09 01072009 AMI. 00000003)
ACPI: OSFR 00000000bf5e51e0 00086 (v01 DELL    M08     07DA0617 ASL  00000061)
ACPI: SSDT 00000000bf5e5268 001BB (v01 Nv1Ref  Nv1Tabl 00001000 INTL 20051117)

ACPI Warning: _BQC returned an invalid level (20091214/video-634)

alg: No test for __ghash (__ghash-pclmulqdqni)
modprobe[52]: segfault at 7fff76bcc038 ip 00007f29baa5dd3b sp 00007fff76b81d50 error 4 in ld-2.12.so[7f29baa5b000+1e000]
modprobe[54]: segfault at 7fff77600038 ip 00007f0a7a794d3b sp 00007fff77558760 error 4 in ld-2.12.so[7f0a7a792000+1e000]
modprobe[57]: segfault at 7fff87efa038 ip 00007fa6c7abdd3b sp 00007fff87ef5330 error 4 in ld-2.12.so[7fa6c7abb000+1e000]
alg: hash: Failed to load transform for ghash-clmulni: -2
Comment 4 Chris January 2010-07-13 08:57:43 EDT
Created attachment 431450 [details]
dmesg log

dmesg log file from booting Fedora 13 x86_64 Live CD.
Comment 5 Chris January 2010-07-13 08:58:07 EDT
Created attachment 431451 [details]
messages log file

messages log file from booting Fedora 13 x86_64 Live CD.
Comment 6 Chris January 2010-07-13 08:58:26 EDT
Created attachment 431452 [details]
boot.log log file

boot.log log file from booting Fedora 13 x86_64 Live CD.
Comment 7 Chris January 2010-07-13 08:59:06 EDT
Created attachment 431453 [details]
Xorg.0.log log file

Xorg.0.log log file from booting Fedora 13 x86_64 Live CD.
Comment 8 Chris January 2010-07-13 09:01:41 EDT
Created attachment 431454 [details]
dmesg log (from working Ubuntu installation)

dmesg log file from working Ubuntu 10.04 installation.
Comment 9 Chris January 2010-07-13 09:27:02 EDT
Created attachment 431463 [details]
diff between dmesg logs from working and non-working boots

diff between dmesg log from a working Ubuntu 10.04 boot (left) and a non-working (i.e. froze after 10 minutes) Fedora 13 boot (right).
Comment 10 Chris January 2010-07-13 14:54:33 EDT
Fedora 13 32-bit also freezes.
Comment 11 Chris January 2010-07-13 15:33:08 EDT
Latest 64-bit kernel in updates (kernel-2.6.33.6-147.fc13.x86_64) also freezes.
Comment 12 Chuck Ebbert 2010-07-14 02:45:48 EDT
Does the kernel from here work any better?

  http://koji.fedoraproject.org/koji/buildinfo?buildID=183346

You'll have to download the proper RPM and install with:

  yum localinstall <package>
Comment 13 Chris January 2010-07-21 03:51:33 EDT
I tried installing that kernel onto a Live USB with persistence. I installed it with yum localinstall, then copied the vmlinuz and initrd files to /syslinux, and edited syslinux.cfg accordingly. It seemed to boot with the right kernel.
However, when the login screen was displayed the screen was corrupted. I will attach a photo.
Comment 14 Chris January 2010-07-21 04:03:55 EDT
Created attachment 433330 [details]
Graphical corruption on login screen booting with 2.6.3.4.1-11.fc13 kernel

I tried booting with the 2.6.34.1-11.fc13 kernel as suggested, but when the boot reached the login screen the login screen was corrupted, as per the photo.
Comment 15 frissony 2010-07-29 21:41:21 EDT
Reporting the exact problem, but not on a Dell. Instead, its on a DIY desktop using a MS Optical Mouse 1000 on USB. The mouse works perfectly with Windows Vista.
Comment 16 vincentvdk 2010-08-05 06:57:17 EDT
Hi, 

I disabled the eSATA and internal card reader, and i was able to install Fedora13_x86_64 from a live USB.
Comment 17 David Strohmayer 2010-10-06 09:32:34 EDT
Hi,

i also experience freezes on my fedora 13 64 bit system. Its a Dell Studio 1558 Notebook.
Comment 18 Vikram Mullachery 2010-10-11 20:35:44 EDT
Hi,
My installation of Fedora 13 64-bit on Thinkpad W510 freezes quite often.
I am re-thinking my choice of this OS for my workstation.
No response to mouse or keyboard - including ctrl+alt+backspace or ctrl+alt+F2, or ctrl+alt+F3 etc. etc. ctrl+alt+del

Last few messages in /var/log/messages below:
Comment 19 Bug Zapper 2011-06-01 10:07:26 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 20 Bug Zapper 2011-06-29 09:38:40 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.