Bug 61384 - up2date fails with --nox
up2date fails with --nox
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-18 16:36 EST by Ben LaHaise
Modified: 2015-01-07 18:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-14 09:53:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben LaHaise 2002-03-18 16:36:16 EST
[root@blip root]# up2date --nox -u
X11 connection rejected because of wrong authentication.
Gdk-ERROR **: X connection to localhost:12.0 broken (explicit kill or server
shutdown).
[root@blip root]# rpm -q up2date
up2date-2.7.11-7.x.2
[root@blip root]#
Comment 1 Adrian Likins 2002-03-18 17:01:17 EST
echo DISPLAY?

output of `which up2date`

Sounds like userhelper not being able to open the display
set in DISPLAY

/usr/sbin/up2date to bypass userhelper

if so, it's fixed in the next version of usermode.
Comment 2 Ben LaHaise 2002-03-18 17:10:55 EST
[root@blip root]# which up2date
/usr/bin/up2date
[root@blip root]# 


Using /usr/sbin/up2date works.
Comment 3 Jason Corley 2002-03-19 17:44:02 EST
I've always SSH'ed into my machines and run up2date --nox to do whatever up2date
functions I need.  I applied the up2date errata on my systems yesterday via
rhn.redhat.com but the RHN web site didn't update the system list
appropriately.  So I logged in to my systems and ran the following:
	[root@ushqappl01 root]# up2date --nox -p
	X11 connection rejected because of wrong authentication.
	Gdk-ERROR **: X connection to localhost:11.0 broken (explicit kill or server
shutdown).
	[root@ushqappl01 root]# rpm -qf `which up2date`
	up2date-gnome-2.7.46-7.x.2
	[root@ushqappl01 root]# rpm -qf /usr/sbin/up2date
	up2date-2.7.46-7.x.2
	[root@ushqappl01 root]# /usr/sbin/up2date --nox -p
	Updating package profile...
	[root@ushqappl01 root]#
This isn't the behavior I'm used to from up2date.  Is this intentional?
Thanks,
Jason
Comment 4 Adrian Likins 2002-03-19 17:58:04 EST
uhm, off hand, that shouldnt of changed. That code path
has really changed (at least, not intentionally...)


It seems to work correctly for me, after ssh'ing
both with a valid DISPLAY and invalid DISPLAY.

If you have a valid DISPLAY, but bogus xauth, that
might be tripping up userhelper. 

Easy way to find out is to run:

    /usr/sbin/up2date 

If that works, it definately a userhelper issue. That
will be fixed with the next release of userhelper.

Off hand, I dont know what would of changed in up2date
that would have made a difference. I'll look into it.

Comment 5 Adrian Likins 2002-03-25 17:44:13 EST
versions of up2date greater than 2.7.62 used in conjuction with
usermode greater than 1.5 should fix this.
Comment 6 Jay Turner 2003-02-14 09:53:07 EST
I'm not seeing any issues running up2date over ssh with up2date-3.1.15-7.

Note You need to log in before you can comment on or make changes to this bug.