Bug 613911 - Guest hangs and gets "virtio_ioport_write" message during virtio-net testing
Guest hangs and gets "virtio_ioport_write" message during virtio-net testing
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 04:21 EDT by Qunfang Zhang
Modified: 2013-01-09 17:51 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 05:00:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qunfang Zhang 2010-07-13 04:21:24 EDT
Description of problem:
As mentioned in :https://bugzilla.redhat.com/show_bug.cgi?id=602607#c18,
create this bug to track the issue on virtio-win side.

This issue often happens when testing "NDIS Test6.0" or "NDIS test 6.5", guest hangs and cannot quit from qemu monitor. There's a lot of message like:

virtio_ioport_write: unexpected address 0x13 value 0x0
virtio_ioport_write: unexpected address 0x13 value 0x0
virtio_ioport_write: unexpected address 0x13 value 0x0
virtio_ioport_write: unexpected address 0x13 value 0x0
virtio_ioport_write: unexpected address 0x13 value 0x0
virtio_ioport_write: unexpected address 0x13 value 0x0
virtio_ioport_write: unexpected address 0x13 value 0x0



Version-Release number of selected component (if applicable):
virtio-win-1.1.7-2
qemu-kvm-0.12.1.2-2.90.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Boot a windows guest and test virtio-net driver, run jobs "NDIS Test6.0" or "NDIS test 6.5"
2.
3.
  
Actual results:
Guest hangs and got lots of "virtio_ioport_write" message.

Expected results:
Test pass.

Additional info:
Comment 1 Yan Vugenfirer 2010-07-13 04:58:24 EDT
Those printout are by design in virtio.

They are part of the debug mechanism in the guest driver that indicates loss (stuck) transfer on QEMU side. 

We will write 0 to VIRTIO_PCI_ISR in case of stuck transfer and "1" in case of blue screen.

The real issue here is the stuck transfer (packers submitted to QEMU but no indication received back).

Note You need to log in before you can comment on or make changes to this bug.