This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 613917 - error: release unlocked lock
error: release unlocked lock
Status: CLOSED DUPLICATE of bug 607650
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Dave Malcolm
BaseOS QE - Apps
anaconda_trace_hash:71405e4c1e49e333b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 04:44 EDT by Pavel Holica
Modified: 2010-09-17 16:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-17 16:15:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (47.96 KB, text/plain)
2010-07-13 04:44 EDT, Pavel Holica
no flags Details
crash screenshot (26.77 KB, image/png)
2010-07-13 04:58 EDT, Pavel Holica
no flags Details

  None (edit)
Description Pavel Holica 2010-07-13 04:44:38 EDT
The following was filed automatically by anaconda:
anaconda 13.21.56 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/threading.py", line 513, in __bootstrap_inner
    _active_limbo_lock.release()
  File "/usr/lib64/python2.6/threading.py", line 497, in __bootstrap
    self.__bootstrap_inner()
error: release unlocked lock
Comment 1 Pavel Holica 2010-07-13 04:44:43 EDT
Created attachment 431390 [details]
Attached traceback automatically from anaconda.
Comment 2 Pavel Holica 2010-07-13 04:58:10 EDT
Created attachment 431393 [details]
crash screenshot

I've encountered this, when anaconda asked me for disk initialization.
I've switched to tty2 and got network running (ifconfig eth0 up && dhclient eth0), then I've provided bugzilla credentials, but instalation continued until partitiong.
No bug was submitted in bugzilla at this point.
I selected Use entire drive option. Partitions started to be formatted and when root partition was formatting, window telling me that bug was submitted to bugzilla popped up.
I clicked OK and another traceback was shown (with similar error). I've tried to send it to bugzilla, but when I provided bugzilla credentials, the X went down and I saw screen provided in attachment.
Comment 4 Dave Malcolm 2010-07-14 19:54:42 EDT
Thanks for filing this bug report.

Can you clarify exactly which tree you saw this with?

Are you able to reproduce this issue?  It would be very useful if you could obtain a coredump from anaconda (I am attempting to track down a simple way of doing this)

Transcribing the error message from the screenshot:
python: Modules/gcmodule.c:277: visit_decref: Assertion `gc->gc.gc_refs != 0' failed.

Corresponding line from the source code is:
/* A traversal callback for subtract_refs. */
static int
visit_decref(PyObject *op, void *data)
{
[snip]
		assert(gc->gc.gc_refs != 0); /* else refcount was too small */
[snip]
}

This happens during the garbage collector if a Python object has been decref-ed too many times: we've seeing if an object is still live by accounting for all of the references that other objects hold to it, but ob_refcnt is lower than the number of such references.  This suggests a reference-counting bug somewhere in the code of either python or an extension module.

Need a coredump to figure out which object it was, and thus where the buggy code is.
Comment 5 Dave Malcolm 2010-07-14 19:55:47 EDT
FWIW, I've filed http://bugs.python.org/issue9263 upstream with a patch to python that may make it easier to track down this kind of bug
Comment 7 Pavel Holica 2010-07-15 04:06:46 EDT
It was RHEL6.0-20100707.4 x86_64 Server with:
anaconda-13.21.56-1.el6
python-2.6.2-11.el6

It happens quiet randomly. I'll try to reproduce it once I have debug image.
Comment 8 RHEL Product and Program Management 2010-07-15 11:10:53 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 9 Pavel Holica 2010-07-23 04:59:20 EDT
I've just hit this bug on RHEL6.0-20100722.0 x86_64 Server (inside KVM again) and anaconda freezes when disks are being detected. But I'm able to execute commands on tty2.
Comment 10 Dave Malcolm 2010-07-27 09:23:17 EDT
Has this only ever happened inside KVM?  If so, this could be another symptom of bug 607650.
Comment 11 Pavel Holica 2010-07-28 04:06:14 EDT
I'm not sure, I've updated kernel yesterday and haven't tried it yet.
It happens quite randomly so it may take time to reproduce this.
Comment 12 Pavel Holica 2010-08-06 07:30:01 EDT
Ok, I haven't hit this bug with new kernel, so it looks like it's duplicate.
Comment 13 Dave Malcolm 2010-09-17 16:15:15 EDT

*** This bug has been marked as a duplicate of bug 607650 ***

Note You need to log in before you can comment on or make changes to this bug.