Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 613969 - strace doesn't log when you call clock_gettime
strace doesn't log when you call clock_gettime
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: strace (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Roland McGrath
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 07:55 EDT by edb_unix
Modified: 2011-05-13 08:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 15:28:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
testprogram (144 bytes, text/plain)
2010-07-13 07:55 EDT, edb_unix
no flags Details
strace of testclock on a 5.4 (5.29 KB, text/plain)
2010-07-13 07:56 EDT, edb_unix
no flags Details
strace of testclock on 6.0 Beta (3.29 KB, text/plain)
2010-07-13 07:57 EDT, edb_unix
no flags Details

  None (edit)
Description edb_unix 2010-07-13 07:55:26 EDT
Created attachment 431431 [details]
testprogram

Description of problem:
Strace doesn't show when you call clock_gettime. If we compare this with our 5.4 machine where it shows.

Version-Release number of selected component (if applicable):
strace-4.5.19-1.5.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Program:
$ cat testclock.c
#include <time.h>
#include <stdio.h>

int main(void)
{
  int intRet;
  struct timespec res;

  intRet = clock_gettime(CLOCK_REALTIME, &res);
}

2. gcc -o testclock -lrt testclock.c

3. strace ./testclock


Actual results:
A strace without any information about calling clock_gettime


Expected results:
Strace should get a result similair to the below (taken from a Red Hat Enterprise 5.4 environment):
clock_gettime(CLOCK_REALTIME, {1279021215, 132738000}) = 0


Additional info:
See attachment for the whole strace results.
Comment 1 edb_unix 2010-07-13 07:56:40 EDT
Created attachment 431432 [details]
strace of testclock on a 5.4
Comment 2 edb_unix 2010-07-13 07:57:20 EDT
Created attachment 431433 [details]
strace of testclock on 6.0 Beta
Comment 4 Roland McGrath 2010-07-13 15:28:10 EDT
There is no bug here.  The clock_gettime call on x86_64 can now sometimes work via the kernel-supplied vDSO without making a syscall.  strace can't trace the call into the vDSO, since it's just user-mode code (albeit kernel-supplied).

Note You need to log in before you can comment on or make changes to this bug.