Bug 61401 - php failed to connect to mysql from web site
Summary: php failed to connect to mysql from web site
Status: CLOSED DUPLICATE of bug 60515
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-19 04:28 UTC by Kenny Fordham
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 08:56:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kenny Fordham 2002-03-19 04:28:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461; Q312461)

Description of problem:
I updated from php-mysql 4.0.6-7 to 4.0.6-12 from the up2date command. After 
that I could not connect to the mysql database from my web site using php.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.I forced the re-install of php & php-mysql 4.0.6-7.
2.
3.
	

Actual Results:  Now it works!

Expected Results:  Now it works

Additional info:

I think Red Hat should check out it's updates to see if they work, before they 
tell us to install them.

Comment 1 Need Real Name 2002-03-27 08:55:59 UTC
My experience:

if you look to PHP info page, there you find:

MYSQL_SOCKET /tmp/mysql.sock

but in /etc/my.cnf is:

socket=/var/lib/mysql/mysql.sock

and in /etc/php.ini is default setting:

mysql.default_socket =

My "non correct" solution (because changing of mysql.default_socket in php.ini 
doesn't have efect):

If you make a link:

ln -s /var/lib/mysql/mysql.sock /tmp/mysql.sock

connection to MySQL will established.

Comment 2 Phil Copeland 2002-03-27 19:21:21 UTC
Current errata (-15)

*** This bug has been marked as a duplicate of 60515 ***


Note You need to log in before you can comment on or make changes to this bug.