Bug 614076 - device-mapper-multipath package should be a requirement
Summary: device-mapper-multipath package should be a requirement
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-13 16:05 UTC by Patrice Guay
Modified: 2010-07-13 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 16:57:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrice Guay 2010-07-13 16:05:16 UTC
The device-mapper-multipath package is a requirement for the /usr/bin/liveinst program shipped by anaconda

Version-Release number of selected component (if applicable):
anaconda 13.21.50-9.el6

How reproducible: always


Steps to Reproduce:
1. Boot on a RHEL6 LiveCD
2. /usr/bin/liveinst
  
Actual results:
anaconda 13.21.50 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iutil.py", line 236, in execWithCapture
    raise RuntimeError, "Error running " + command + ": " + e.strerror
  File "/usr/lib/anaconda/storage/devicelibs/mpath.py", line 80, in identifyMult
ipaths
    topology = parseMultipathOutput(iutil.execWithCapture("multipath", ["-d",]))
  File "/usr/lib/anaconda/iw/filter_gui.py", line 570, in getScreen
    (singlepaths, mpaths, partitions) = identifyMultipaths(disks)
  File "/usr/lib/anaconda/gui.py", line 1415, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1336, in nextClicked
    self.setScreen ()
RuntimeError: Error running multipath: No such file or directory


Solution:
By installing the device-mapper-multipath package, this error is avoided.

Comment 2 Chris Lumens 2010-07-13 16:57:05 UTC
anaconda cannot simply require device-mapper-multipath, because not all composes of RHEL6 contain that package.  Placing a hard requirement on it would therefore break tree composition and likely anaconda builds.


Note You need to log in before you can comment on or make changes to this bug.