Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 614080 - SELinux verhindert /usr/sbin/smartctl "sys_rawio" Zugriff .
SELinux verhindert /usr/sbin/smartctl "sys_rawio" Zugriff .
Status: CLOSED DUPLICATE of bug 614078
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:ca8c75f3167...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 12:12 EDT by Till Maas
Modified: 2010-07-14 03:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 03:30:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2010-07-13 12:12:21 EDT
Zusammenfassung:

SELinux verhindert /usr/sbin/smartctl "sys_rawio" Zugriff .

Detaillierte Beschreibung:

[SELinux ist in freizügigem Modus. Dieser Zugriff wurde nicht verweigert.]

SELinux verweigerte den von smartctl angeforderten Zugriff. Da nicht davon
ausgegangen wird, dass dieser Zugriff von smartctl benötigt wird, signalisiert
dies möglicherweise einen Einbruchsversuch. Es ist ausserdem möglich, dass
diese spezielle Version oder Konfiguration der Anwendung den zusätzlichen
Zugriff verursacht.

Zugriff erlauben:

Sie können ein lokales Richtlininenmodul generieren, um diesen Zugriff zu
erlauben siehe FAQ (http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385)
Bitte reichen Sie einen Fehlerbericht ein.

Zusätzliche Informationen:

Quellkontext                  system_u:system_r:munin_disk_plugin_t:s0
Zielkontext                   system_u:system_r:munin_disk_plugin_t:s0
Zielobjekte                   None [ capability ]
Quelle                        smartctl
Quellpfad                     /usr/sbin/smartctl
Port                          <Unbekannt>
Host                          (entfernt)
RPM-Pakete der Quelle         smartmontools-5.39.1-1.fc12
RPM-Pakete des Ziels          
Richtlinien-RPM               selinux-policy-3.6.32-118.fc12
SELinux aktiviert             True
Richtlinientyp                targeted
Enforcing-Modus               Permissive
Plugin-Name                   catchall
Rechnername                   (entfernt)
Plattform                     Linux (entfernt)
                              2.6.32.14-127.fc12.x86_64 #1 SMP Fri May 28
                              04:30:39 UTC 2010 x86_64 x86_64
Anzahl der Alarme             168
Zuerst gesehen                Do 06 Mai 2010 19:25:12 CEST
Zuletzt gesehen               Mo 12 Jul 2010 19:35:10 CEST
Lokale ID                     876e2910-b32b-4d25-a039-1027c7657ca0
Zeilennummern                 

Raw-Audit-Meldungen           

node=(entfernt) type=AVC msg=audit(1278956110.5:2101): avc:  denied  { sys_rawio } for  pid=15605 comm="smartctl" capability=17  scontext=system_u:system_r:munin_disk_plugin_t:s0 tcontext=system_u:system_r:munin_disk_plugin_t:s0 tclass=capability

node=(entfernt) type=SYSCALL msg=audit(1278956110.5:2101): arch=c000003e syscall=16 success=yes exit=0 a0=3 a1=2285 a2=7fffd877ce20 a3=10 items=0 ppid=15599 pid=15605 auid=4294967295 uid=0 gid=470 euid=0 suid=0 fsuid=0 egid=470 sgid=470 fsgid=470 tty=(none) ses=4294967295 comm="smartctl" exe="/usr/sbin/smartctl" subj=system_u:system_r:munin_disk_plugin_t:s0 key=(null)



Hash String generated from  catchall,smartctl,munin_disk_plugin_t,munin_disk_plugin_t,capability,sys_rawio
audit2allow suggests:

#============= munin_disk_plugin_t ==============
allow munin_disk_plugin_t self:capability sys_rawio;
Comment 1 Daniel Walsh 2010-07-13 13:59:08 EDT
Probably alright.
Comment 2 Miroslav Grepl 2010-07-14 03:30:20 EDT

*** This bug has been marked as a duplicate of bug 614078 ***

Note You need to log in before you can comment on or make changes to this bug.