Bug 614083 - livecd.py - 'Anaconda' object has no attribute 'keyboard'
livecd.py - 'Anaconda' object has no attribute 'keyboard'
Status: CLOSED DUPLICATE of bug 601159
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 12:14 EDT by Patrice Guay
Modified: 2010-07-16 10:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-16 10:16:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use the appropriate anaconda object for keyboard manipulation (559 bytes, patch)
2010-07-13 12:14 EDT, Patrice Guay
no flags Details | Diff

  None (edit)
Description Patrice Guay 2010-07-13 12:14:30 EDT
Created attachment 431506 [details]
Use the appropriate anaconda object for keyboard manipulation

Description of problem:
While running the liveinst program under a LiveCD environment, the program will produce an error on the post-installation stage.

Version-Release number of selected component (if applicable):
anaconda 13.21.50-9.el6

How reproducible:
always

Steps to Reproduce:
1. Boot a RHEL6 LiveCD
2. /usr/bin/liveinst
  
Actual results:
The program will fail in the post-installation stage with the following error:
AttributeError: 'Anaconda' object has no attribute 'keyboard'

Additional info:
After reviewing the /usr/lib/anaconda/livecd.py file, I produced a patch to fix the issue. See the attached file.
Comment 3 Chris Lumens 2010-07-16 10:16:16 EDT
Ah, looks like we already fixed this one in anaconda-13.21.51-1

*** This bug has been marked as a duplicate of bug 601159 ***

Note You need to log in before you can comment on or make changes to this bug.