Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 614134 - kdm_greet denials
kdm_greet denials
Status: CLOSED DUPLICATE of bug 588130
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 14:04 EDT by Orion Poplawski
Modified: 2010-07-15 23:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 23:47:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2010-07-13 14:04:36 EDT
Description of problem:

Get this on either login or logout, not sure which:

type=AVC msg=audit(1278952221.327:2970): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="drkonqi" dev=sda2 ino=1439228 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=file
type=AVC msg=audit(1278952222.798:2971): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="startkde" dev=sda2 ino=1322024 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=file
type=AVC msg=audit(1278952222.799:2972): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="startkde" dev=sda2 ino=1322024 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=file
type=AVC msg=audit(1278952222.811:2973): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="startxfce4" dev=sda2 ino=1343532 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=file
type=AVC msg=audit(1278952222.917:2974): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="kde4" dev=sda2 ino=1446037 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=dir
type=AVC msg=audit(1278952222.917:2975): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="bin" dev=sda2 ino=1308247 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=dir
type=AVC msg=audit(1278952222.918:2976): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="sbin" dev=sda2 ino=1308268 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=dir
type=AVC msg=audit(1278952222.918:2977): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="bin" dev=sda2 ino=1308262 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=dir
type=AVC msg=audit(1278952222.918:2978): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="sbin" dev=sda2 ino=1308162 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=dir
type=AVC msg=audit(1278952222.918:2979): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="bin" dev=sda2 ino=1308247 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=dir
type=AVC msg=audit(1278952222.919:2980): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="sbin" dev=sda2 ino=1962241 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=dir
type=AVC msg=audit(1278952222.919:2981): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="bin" dev=sda2 ino=1700610 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=dir
type=AVC msg=audit(1278952223.078:2982): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="startxfce4" dev=sda2 ino=1343532 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=file
type=AVC msg=audit(1278952223.225:2983): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="lnusertemp" dev=sda2 ino=1462284 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=file
type=AVC msg=audit(1278952223.266:2984): avc:  denied  { write } for  pid=15548 comm="kdm_greet" name="lnusertemp" dev=sda2 ino=1462284 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=file

Version-Release number of selected component (if applicable):
kdm-4.4.92-1.fc13.i686
selinux-policy-3.7.19-33.fc13.noarch

This is kde from the kde-unstable repo.
Comment 1 Carl G. 2010-07-13 21:08:44 EDT
Might be a dupe of :

https://bugzilla.redhat.com/show_bug.cgi?id=588130

Can you tell us if you customized kdm/kdmrc? Also, if you don't have setroubleshoot installed you can run audit2why / audit2allow?

Thank you

 
---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Carl G. 2010-07-15 23:47:44 EDT

*** This bug has been marked as a duplicate of bug 588130 ***

Note You need to log in before you can comment on or make changes to this bug.