Bug 614139 - Report throws traceback when there is a configuration for a non-present plugin
Report throws traceback when there is a configuration for a non-present plugin
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: report (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Gavin Romig-Koch
David Kutálek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 14:15 EDT by David Kutálek
Modified: 2010-11-10 16:29 EST (History)
0 users

See Also:
Fixed In Version: report-0.18-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:29:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kutálek 2010-07-13 14:15:31 EDT
Description of problem:

During testing, I modified my main configuration file at /etc/report.conf to include config for all plugins. After uninstalling plugin for bugzilla (obsoleted now), I am getting traceback because of bugzilla plugin config is still present in main config:

[dkutalek@timothy Documents]$ report /tmp/dummy-report.txt 
Traceback (most recent call last):
  File "/usr/bin/report", line 160, in <module>
    app = report.report(signature, io, **optsDict)
  File "/usr/lib64/python2.6/site-packages/report/__init__.py", line 489, in report
    choice = buildChoices(signature, io, config, rptopts)
  File "/usr/lib64/python2.6/site-packages/report/__init__.py", line 398, in buildChoices
    (modulefile, modulepath, moduletype) = imputil.imp.find_module(moduleName,alternatives.__path__)
ImportError: No module named RHEL-bugzilla

Although it can be considered as misconfiguration by user, it definitely should not traceback because of it. Giving a simple text warning to stderr and continue should be nice enough.

Version-Release number of selected component (if applicable):

report-0.18-2.el6.x86_64

How reproducible:

Always

Steps to Reproduce:
1. insert a configuration for any uninstalled plugin
2. run report
  
Actual results:

Traceback

Expected results:

Only give a warning and continue.

Additional info:

Under usual circumstances not triggered, because configuration for individual plugins is kept in separate files and these are removed when removing plugin via package dependency. However, it can happen when user plays with main config as happened to me.
Comment 3 RHEL Product and Program Management 2010-07-15 10:49:11 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 6 releng-rhel@redhat.com 2010-11-10 16:29:48 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.