Bug 61424 - X wont start in spite of default runlevel being 5
Summary: X wont start in spite of default runlevel being 5
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-19 14:47 UTC by Eskil Swahn
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-19 14:47:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eskil Swahn 2002-03-19 14:47:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; OSF1 V5.1 alpha)

Description of problem:
Hi!

All of a sudden my newly installed RH 7.2 (about an week old) wont start X when
I boot the computer. Instead I just get the normal command prompt and can login
and then write 'startx' and GNOME will start. It will however complain that my
hostname can't be found. I found that the reason for this is that my
/etc/resolv.conf isn't being generated properly at startup anymore. It will be
missing the line 'search my_domain.com'. I'm not quite sure why it suddenly
isn't being generated correctly (I am using DHCP) or if it is the reason why X
wont start automatically or if it is just another indication of something even
more serious being broke. If I manually add 'search my_domain.com' to
/etc/resolv.conf before I write 'startx' GNOME will start without complaints.
Even with the complaint it will however start when I do it manually. At first I
thought something was wrong with my specific installation but then I heard that
a friend of mine has the exact same problem and I also saw a post in your
support forums about the very same problem (without solution unfortunately)
leading me to believe that this might perhaps be a known easy-to-fix  problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Hmm.. I just boot the system.. =)
	

Actual Results:  I just get the console based login prompt

Expected Results:  I would had liked the 'gdm'-login instead but I never get to
see this anymore.

Additional info:

This is a plain vanilla RH 7.2 updated to all the latest RPMs through 'update
agent'.

Comment 1 Mike A. Harris 2002-03-22 04:07:56 UTC
This is not a bug, rather a technical support/configurability issue.
Bugzilla is only for bug tracking, and is not intended for providing general
technical support.  Please try our mailing lists or other support forums
to work out this local configuration issue.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.